Change mac address with macchanger Linux command -

In some situations you need to fake / change / spoof a MAC address of your network interface. macchanger Linux command does this job in no time. With this tool you can change your mac address of any Ethernet network device wired or wireless. Here is a small example:
This is a companion discussion topic for the original entry at

agbo emmanuel

Thanks, it worked perfectly.


I lose internet everytime I change my mac

Karthick Arasappan -> Learncode

because, you mac ID would have been patched with the network you be within !


My MAC address does not change… in the CLI
sudo macchanger -a blahblah
It gives me a new mac address, but (of course the adapter is down when I’m performing this) when I turn the adapter back on, It still remains the same as if I never touched MACchanger.
ifconfig tells me my MAC address is the same as if it always have, but macchanger tells me it has changed it.

Doubled check by checking the MAC address on my router and yep… Nothing changed at all.
Need some help. Btw I’m on linux mint. I don’t want to add another OS on my machine. I don’t really like Kali Linux. I’d be happier if I’m able to perform this on Mint. Don’t tell me to delete change my network manager…

Manoj Karajada

i am connect to wlan0
when i am running macchanger -r wlan0
it shows error could not change MAC : interface up or insufficient permissions : device or resource busy

Abdelilah Akebli -> Manoj Karajada

Ifconfig wlan0 down . an then change the mac address

RaviTeja Paruchuri -> Manoj Karajada

hey dont u under whats meant by ifconfig wlan0 down it will disconnect u from network
so with making n/w down u cann’t change maccaddress

Lubos Rendek -> Manoj Karajada

Try to disable your wlan0 interface. macchanger would not change MAC if the interface is up.


Is there any way to change permanently, i mean i want the change to be reflect after reboot as well.

Lubos Rendek -> TecGeeks

Yes there is! Open your /etc/network/interfaces file and add hwaddress ether 02:01:02:03:02:06 into a iface stanza. For example change:

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp


# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
hwaddress ether 02:01:02:03:02:06

This will set a mac address of eth0 to 02:01:02:03:02:06 which will persist after reboot.

Hope it helps! :slight_smile:


It worked, but only when I’m disconnected from a wifi network. When I connect to wifi, I can see the MAC is reset with ifconfig… :confused:
I have this problem on Debian or Arch.

M-LA | Consultant -> Rivington


Can I ask. I tried the utility, but I have another line that says “Permanent MAC”

When I change the address and use IP config, it stays at the original address. Does my computer have something that does this?

ifconfig enp3s0 down
macchanger -r enp3s0
e0:ca:94:aa:ba:ab (xxx Computer)
Permanent MAC: 4a:33:b9:1d:c7:3a (Joe Corporation)
New MAC: fe:5e:80:41:32:09 (unknown)