Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable) - Linux Mint


#1

Hi
Tried to install but got this text, is this OK looked a bit off

$ sudo apt install gddrescue
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libllvm4.0:i386 libllvm5.0 libllvm5.0:i386 mint-backgrounds-serena
  mint-backgrounds-sonya mokutil python3-xlib
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed
  gddrescue
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/cache/apt/archives/

Broadcom Corporation BCM43142 - Linux Mint - not working
#2

Hey Phil,

Some other process where holding apt’s lock when you tried to install. Simply re-run the install and you should be fine.


#3

Yes, most likely update is running on the background. Please visit Disable Automatic Updates on Ubuntu as a possible solution. Also make sure that you have Not initiated apt upgrade or apt install session on some other terminals as this may also cause Could not get lock error.

However, as @sandmann mentioned. Simply wait and re-run the apt install command again.