Debian - No sound problem - KDE


#1

HI,

It all looks good in terms modules installed and everything but I do not get a single sound our af the system. I did check the usual like mixer, volume, drivers and so on but I could not find a problem.

What I’m thinking of is that it may be some conficlit with my two sound cards as a recently added new video card which has a sound build in and uses HDMI. Here are the two devices I’m talking about:

01:00.1 Audio device: ATI Technologies Inc Device aa88
00:0f.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)

I do not use and prefer HDMI however I did test it and no sound anyway.

Here is a output of lsmod:

$ lsmod | grep snd
snd_hda_codec_atihdmi     1687  1 
snd_hda_codec_analog    45530  1 
snd_hda_intel          16823  1 
snd_hda_codec          46002  3 snd_hda_codec_atihdmi,snd_hda_codec_analog,snd_hda_intel
snd_hwdep               4054  1 snd_hda_codec
snd_pcm                47226  2 snd_hda_intel,snd_hda_codec
snd_seq                35463  0 
snd_timer              12270  2 snd_pcm,snd_seq
snd_seq_device          3673  1 snd_seq
snd                    34423  10 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore               3450  1 snd
snd_page_alloc          5045  2 snd_hda_intel,snd_pcm

When running alsamixer it seem to be set to:

────────────────────────────── AlsaMixer v1.0.23 ───────────────────────────────┐
│ Card: HDA NVidia                                       F1:  Help               │
│ Chip: Analog Devices AD1988B                           F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All               F6:  Select sound card  │
│ Item: Master [dB gain: 0.00]                           Esc: Exit           

Volume is up. I’m not sure what else I should try but I have this feeling that it is something silly :slight_smile:

thank you


#2

Blacklist pcspkr and reboot.


#3

blacklisting PC speaker did not help at all. Any other thoughts…?


#4

Did you reboot? Also please paste the whole output of lsmod and lspci -v


#5

Yes, I did reboot. I also run lsmod again to confirm that pcspkr is not loaded.

Please find attached files with requested output:

thank you


#6

The output looks OK. Is your user part of the audio group? Also, please tell me what does ‘uname -a’ say.


#7

Yes it is part of audio group. Sorry I forgot to mention that before:

$ id `whoami`
uid=1000(lilo) gid=1000(lilo) groups=1000(lilo),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev)

uname -a:

$ uname -a
Linux thebeast 2.6.32-5-686 #1 SMP Thu Nov 3 04:23:54 UTC 2011 i686 GNU/Linux

#8

I strongly recommend you install a kernel from backports. There are lots of new and improved drivers since 2.6.32.


#9

my first card

 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xefff0000 irq 20

did work before with debian I’m sure of that so installing kernel from backports seems to be quite drastic solution at the moment.


#10

Ok…I had to try kernel from back-ports:


linux-image-2.6.38-bpo.2-686

Did not help same problem and what’s more it broke my vga driver driver so it was completely unusable. Using back ports is not an option…

any other ideas…?


#11