Get udev running for from scratch (Parted Magic)

Ahoy friends.
For almost 2 months i was trying to get Parted Magic running properly on my PXE Server.
Unfortunately the Parted Magic system does not offer any NFS root support --> so booting from Network is extremely slow.
So after trying a lot of things, compiling own Kernel, generating own initramfs files i’m stuck.
I got the system running by using the Debian Live vmlinuz and initrd file and renaming the Parted Magic SQFS file to filesystem.squashfs.
And finally i’m able to boot!
But i can’t move my mouse or use my keyboard.


Alright then. So i checked what Parted Magic needs to boot.
There are 2 more files, one called m.sqfs and fu.sqfs. They contain firmware and some udev script.
The original initrd does not offer any nfs support but some udev stuff, but i don’t know how to include it in my new initrd, or how to get it running using another way.
I tried to replace the /lib folder and /etc/udev folder already by the debian-live ones, but it didn’t work so well.
So what do i have to do to get my usb devices running properly again?
I also tried to include the folders of the m.sqfs and fu.sqfs file in the main filesystem.squashfs file but still having the same issue.

Here i got the init file from the Parted Magic initrd.

https://pastebin.com/LbbKRezX

And the Debian Live one. Any idea how to include things from Parted Magic there? Or any other solution how to get the hardware loaded?

https://pastebin.com/iL1w3u5e

Hello Knogle,
Welcome to the forum.
Are you attempting this in Virtualbox or in a physical server?
If in VB, have you tried to change the type of mouse device in the system properties?
Anyhow it does seem strange to me the keyboard doesn’t work, it might be the system has hung or maybe your custom kernel was not compiled with USB Human Interface Device (HID) support?