How to configure static IP address on Ubuntu 19.04 Disco Dingo Linux - LinuxConfig.org

This article will provide you with an information on how to configure a static IP address on Ubuntu 19.04 Disco Dingo Linux

In this tutorial you will learn:

  • How to configure static IP address using netplan
  • How to configure static IP address from Graphical User interface ( GUI )

This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-configure-static-ip-address-on-ubuntu-19-04-disco-dingo-linux

I don’t get any of the above as my system seems to have install a cloud-init networking (which i didn’t want). Maybe I missed something on the install but looks like Ubuntu have gone down the microsoft route here. What was wrong with keeping to standard linux and offering clouded stuff as options not defaults ? How do I get rid of this now and go back to the old standards such as network manager. I have installed network manager but no command line / no gui / no options.

Hi Steve Downing,

Welcome to our forums.

Your issue sounds like not the default installation process of Ubuntu. What installation media do you use, and on what system did you install the operating system?

The server installer ubuntu-19.04-live-server-amd64.iso . I do recall agreeing to enable openssh-server , in the install but otherwise chose defaults (I think). More’s the point is it now a matter of a complete re-install ?

If you just installed the system, the cleanest way is certainly reinstall, but if you only missing the setup tools for NetworkManager you could try something like:

# apt-get install network-manager-gnome

In case you need the graphical setup tool. Command line tools like nmcli should be present and accessible as root if you installed NetworkManager from the official repositories. Does an

# nmcli --version

Provide command-not-found like error?

Doing a complete re-install andd noticed in the logs that after installing openssh it then installs cloud-init. So perhaps I am correct and cloud-init is becoming the default if you choose openssh -server. I shall see but looks like yet another install might be needed and not choose openssh and just install that later. I did install network-manager the first time but cloud-init had assumed control of my network config.