How to install Docker on Fedora 31 - LinuxConfig.org

This tutorial will provide you with simple to follow steps on how to install Docker on Fedora 31 Linux.
This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-docker-on-fedora-31

Did you actually try it?
I don’t mean to be mean, but the tutorial appears to be a copy and paste from older versions with only the version number updated to 31 and not taking into consideration that Fedora 31 is using cgroup v2 - which doesn’t work well together with docker.

This article might have the missing steps:
https://medium.com/nttlabs/cgroup-v2-596d035be4d7

Hi Bearny,

Thank you for bringing this to my attention. It was not copy and paste however proper testing was missing. I simply assumed that once the docker service is up and running it all should be ready to go. As it turned out I could not be more wrong.

Once I tried to run container I got an error:

Status: Downloaded newer image for hello-world:latest
docker: Error response from daemon: OCI runtime create failed: container_linux.go:346: starting container process caused "process_linux.go:297: applying cgroup configuration for process caused \"open /sys/fs/cgroup/docker/cpuset.cpus.effective: no such file or directory\"": unknown.
ERRO[0007] error waiting for container: context canceled 

Reverting back to cgroup v1 using:

$ sudo dnf install -y grubby
$ sudo grubby --update-kernel=ALL --args="systemd.unified_cgroup_hierarchy=0"
$ sudo reboot

alternatively running starting a docker container as:

$ podman run --rm docker.io/library/hello-world

Resolved the cgroup configuration error. The article will be updated shortly.

thank you

Lubos

Hey there, one suggestion for improvement:
grubby --update-kernel=ALL --args=“systemd.unified_cgroup_hierarchy=0” --make-default

“–make-default”
should make the additional kernel arguments update-proof.

Ben