How to install Google Chrome Browser on Kali Linux - LinuxConfig.org


#1

The objective is to install Google Chrome web browser on Kali Linux. See an appendix for a possible issue troubleshooting.


This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-google-chrome-browser-on-kali-linux

NOTE: SOME OF THE POSTS BELOW ARE TRANSFERRED FROM LINUXCONFIG DISQUS COMMENTS.

#2

Jacob Ashigbi

can someone help pls?

errors were encountered while processing

insecure connection error on Kali

when I issued the gdebi command the response is
bash: gdebi: command not found


#3

Thomas Smets

???
root@caraff:~# su linuxconfig -c google-chrome-stable
No protocol specified

(google-chrome-stable:80622): Gtk-WARNING **: 18:02:18.805: cannot open display: :1

Any idea ?


#4

Anjani Dhiman

First download the package from google itself, change directory location to where the chrome package is stored, in my case is Downloads.
then
$ su
password: (root password)
# dpkg -i google-chrome-stable_current_amd64.deb
# exit
$ google-chrome-stable.


#5

KushiBro

im 32 bit user please help


#6

aziz sa

gdeb -i google-chrome-stable_current_amd64.deb
bash: gdeb: command not found

#7

Lubos Rendek Mod -> aziz sa

not gdeb but gdebi! You are missing the “i” :slight_smile:


#8

cevhyruz

for anyone having the libappindicator1 dependency problem just update your sources list and perform an apt-get update then dpkg -i to install chrome and apt-get -f to install dependency


#9

Gautam Maru

when I open google-chrome its dipalyed this MSG:

Please start Google Chrome as a normal user. If you need to run as root for development, rerun with the --no-sandbox flag.

can anybody guide me?


#10

cevhyruz -> Gautam Maru

run it with --no-sandbox flag in terminal or use an account that not in the sudoer file


#11

MD Tahidur Rahman Tuhin

root@kali:~# google-chrome
bash: google-chrome: command not found

why this happening ?


#12

oslohes tyagi

when I do su linuxconfig -c google-chrome
i get

No protocol specified

(google-chrome:25067): Gtk-WARNING **: cannot open display: :0

#13

oslohes tyagi

make sure to put the file on the Desktop and then cd Desktop


#14

Noble -> oslohes tyagi

What file you mean?


#15

Danish Faraz

that didnt workd for me i got stuck in

gdebi google-chrome-stable_current_amd64.deb

step itself it couldnt able to recognise gdebi command

help me out i badly need chrome


#16

Cheyenne Forbes -> Danish Faraz

try installing gdebi with “apt-get install gdebi” in the terminal before following these steps


#17

solomon -> Cheyenne Forbes

E: Unable to locate package gdebi
why is it showing so ???


#18

Dax -> Cheyenne Forbes

that command didnt install gdebi pls what other options


#19

Harshil Gupta -> Dax

$ su
password: (root password)
# dpkg -i google-chrome-stable_current_amd64.deb
# exit
$ google-chrome-stable

#20

oslohes tyagi -> Dax

it worked for me

Thank you very much