How to Install Latest Adobe Acrobat Reader DC on Ubuntu 18.04 Bionic Beaver Linux with Wine - LinuxConfig.org


#1

The objective is to install the latest version of Adobe Reader on Ubuntu 18.04 Bionic Beaver Linux desktop using Wine.

Wait until the setup is completed and click on Finish:

Start Adobe Acrobat Reader by searching your start menu or by clicking on the Acrobat Reader DC.desktop and confirm the Untrusted application launcher window by clicking on Trust and Launch icon:


This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-latest-adobe-acrobat-reader-dc-on-ubuntu-18-04-bionic-beaver-linux-with-wine

#2

Hi…
The information is very intuitive, and worked for me in Ubuntu 18.04 installation.
But when i am following the same in LUbuntu 18.04 i am not able to install the Adobe reader and the same is getting interrupted in between.
Can u please help me in the same matter.
Regards
Abhinav Aggarwal


#3

Hello,

I have installed a fresh Lubuntu system and followed the guide and it all worked as expect. See the screenshot below:

What errors you are receiving? Could they be caused by internet connection, low disk space etc.?

Lubos


#4

Dear Lubos,

I did everything as written in the instruction. Somehow, at the very end, I get the following message, which I don’t understand. I’m pretty new to Ubuntu and have to find my way through the system.

Thanks for help…

Best Regards

Logellvion


#5

Hello Logellvion,

[Ubuntu 18.04] ERROR: ld.so: object ‘libgtk3-nocsd.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored

Have you tried to install libgtk3-nocsd0:i386 package to see if this resolves the issue.

$ sudo apt-get install libgtk3-nocsd0:i386

Hope this helps…

Lubos


#6

Hi, could you please tell me how to uninstall this?


#7

PROBLEM THE RESOLUCTION


#8

Hi there,
Could you please help me solve the problem I’ve had during installation. I did everything according to the guide above, but I got this message.
Thanks.

image


#9

Same as Ruslan above. It seems adobe is now doing some kind of check to keep wine installs out.


#10

I think it’s complaining about the wine configuration… I got past this by creating a new win32 wine directory and following the directions as above:
WINEARCH=win32 WINEPREFIX=~/win32 winecfg
WINEARCH=win32 WINEPREFIX=~/win32 winetricks mspatcha
WINEARCH=win32 WINEPREFIX=~/win32 wine AcroRdrDC1800920044_en_US.exe


#11

I had the same issue as @Ruslan_Yanyshyn. Setting the Windows version to Windows 7 in winecfg fixed the issue.

By default it was set to WinXP on my Ubuntu 18.04.

Best,
Matthias


#12

_ @Lubos Thanks for the procedure.
I have tried the latest version i.e Adobe Reader DC 2019.010.20064 for window 10 downloaded directly from following link.
Link:get.adobe.com/reader/download/?installer=Reader_DC_2019.010.20064_English_UK_for_Windows&stype=7438&standalone=1

To open Just right click on pdf file -> Select “Open with other application” -> View all application -> Select “Adobe acrobat DC”

The above problem can be solved by downloading and installing window fonts from link:www.w7df.com/7/download.html

It works good and files are opened without error. But it following features:

  • Highlights, strike through, replace note work but the comments are too small i.e., size 2.
  • Text in sidebar for tools are not visible.
  • The logo in menu-bar options are also not visible.

System:
OS : Ubuntu 18.04 64bit
Desktop Environment : GNOME Shell 3.28.3
Kernal : Linux version 4.15.0-43-generic


#13

Follow these steps:

  1. Get the Windows 7 fonts, especially the sego* fonts.
    Note : You can get window fonts from here: link:www.w7df.com/7/download.html

  2. Copy the windows fonts to a folder in /usr/share/fonts

  3. execute this command in a terminal:
    sudo fc-cache -vf

Source : link:askubuntu.com/questions/1069103/missing-fonts-in-acrobat-reader-in-wine/1103305#1103305