How to install Minecraft on Ubuntu 18.04 Bionic Beaver Linux -

The objective is to install the Minecraft client on Ubuntu 18.04 Bionic Beaver Linux. The installation of the Minecraft client on Ubuntu 18.04 Linux with use of snap is as easy as an execution of a single command. Open up terminal and enter:
$ sudo snap install minecraft

This is a companion discussion topic for the original entry at

Lassemind Mind

Hey guys,
somehow my laucher has gotten updated to the now one and now i somehow cant lauche minecraft, what now??

No one you know

i have run:

“sudo snap install minecraft”

and after doing some other stuff it responded:

“minecraft latest from ‘snapcrafters’ installed”.

When i run “minecraft” it gives me this:

"Command ‘minecraft’ not found, but can be installed with:

sudo snap install minecraft"
If i try to installing it again it just tells me it is already installed and no change when i try to run it.

i am running Lubuntu 18.04 LTS


I don’t have a rescource pack folder…

Em Jannings (Emil)

Snap solved a problem for me. After upgrading to 18.04 I installed java and Minecraft.jar and experienced a series of crashes involving the “trustAnchors parameter” that I could not solve. Snap installed the launcher with one command. I don’t find that this launcher any different that the ones I’ve use before.

As for the snap “silo” I think a silo is probably a pretty good place to put java. I recommend this installation.

Callista Graves

Sorry, but the problem with this is it is not at all friendly for the average Minecraft player.

How does one install mods? Do you need to know how to make snap packages to do so?

Minecraft as a snap removes options for users, putting the data into a sort of silo.

popeydc -> Callista Graves

The .minecraft folder is in ~/snap/minecraft/common and so mods and other things can be placed in there. It’s not a lot different from the other ways of installing Minecraft, the folder just moved a little :slight_smile:

Sea Star -> popeydc

Forge doesn’t seem to work on Ubuntu 18.04 as of right now. The folder and launcher are indeed there, but the forge installer can’t seem to find them, even when directed to the location.

I’m running a newly installed “Ubuntu 18.04” and I can’t find any “minecraft” snap.

madmike@ubuntu-desktop:~$ sudo snap install minecraft
Fehler: Snap “minecraft” konnte nicht gefunden werden
madmike@ubuntu-desktop:~$ snap install minecraft
Fehler: Snap “minecraft” konnte nicht gefunden werden

I can’t find it on snapcraft_io either.

It seems I need to install minecraft the old way… installing java first then minecraft.jar and so on :stuck_out_tongue:

Can you either update your guide or mark it as absolete? Your the N°1 search result and I guess more people like me are going to stumble over this with similar results. :frowning:

Hi Paul,

Thanks for bringing this to our attention. Yes, it seems that the Minecraft package has been removed or temporarily unavailable. I guess this is the downside of the snap package management. Absolutely no control and no warning.

I have updated the article to include the installation of minecraft from the official Minecraft package. The new version of this article will be published shortly.


I followed the instructions for the official package, but after:

sudo gdebi ~/Minecraft.deb

I got the following problem:

Reading package lists... Done
Building dependency tree        
Reading state information... Done
Failed to open the software package
The package might be corrupted or you are not allowed to open the file. Check the permissions of the file.

How should I solve this?


Have you tried to use dpkg to install the deb package? For example:

$ sudo dpkg -i ~/Minecraft.deb
$ sudo apt-get install -f

Hope this helps…


Thanks for the suggestion.
But now I get this error:

peter@peter-Inspiron-530:~$ wget -o ~/Minecraft.deb
peter@peter-Inspiron-530:~$ sudo dpkg -i ~/Minecraft.deb
dpkg-deb: error: '/home/peter/Minecraft.deb' is not a Debian format archive
dpkg: error processing archive /home/peter/Minecraft.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:

Hi Peter,

I had this same problem, and found that the Minecraft.deb file actually contained the verbose output of the wget operation (which I had been surprised not to see written to stdout while the command was executing). However there was another file called Minecraft.deb.1, which was much larger, which was the one I wanted. I deleted the first and renamed the second to Minecraft.deb, and from there the gdebi command worked as described.

Hope this helps,

1 Like

Peter and Paulie, the problem is with the ‘wget’ command and the ‘-o’ option.

-o filename creates the logfile at filename

-O filename saves the download file to filename

Case sensitive switches. The original author needs to make this change to show -O instead of -o. The reason why the .1 file existed is because the filename was already created (logfile) and it appends the .1 .2 .3 .4 for identical filenames.

So the actual .deb download command if you want to create a logfile should look like this

wget -o Minecraft.log -O Minecraft.deb “URL” (being a new poster its not allowing me to post the href)

you can also eliminate the output and just watch the output stdout instead which would be

wget -O Minecraft.deb “URL”

At least this way you can see the progress of your download.

Hope this helps the 2 of you and others following the .deb download version of the author.


1 Like

thanks mate this fixed my issue as well