How to install Nvidia driver on Debian 10 Buster Linux - LinuxConfig.org

In this article you will learn how to install Nvidia driver on Debian 10 Buster from the standard Debian repository. In case that from some reason the installation of the Nvidia driver from the standard Debian repository failed or you simply with to have more up to date Nvidia driver installed this tutorial will also explain on how to install the official Nvidia driver driver directly downloaded from the Nvidia.com website.
This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-nvidia-driver-on-debian-10-buster-linux

Hay man
You need add contrib to sources.list and non-free

The non-free Debian repository should be all that is required to follow this tutorial. Can you provide more information on why do you think that the contrib repository is required?

thank you

Actually, just the non-free repository is not enough to install all the dependencies required for nvidia-driver, adding the contrib repository solved my case.

Adding non-free is not enough. Other commenter is correct. The nvidia-driver package has a number of dependencies on packages available in contrib that are not present in non-free.

I’m on Debian 10 and for some reason just blacklisting the nouveau driver through the conf file wasn’t enough. I also had to run “update-initramfs -u” for it to actually blacklist it. Never experienced that on Debian 9.x. I wonder what changed?

1 Like

I did all steps in this article exactly but I didn’t get correct result! I got a dark screen، It seems this article is incomplete :neutral_face:

Yes, it forgets to mention that before installing nvidia-driver you need to

sudo apt-get install module-assistant

and run

sudo m-a prepare

It will install missing kernel header files for compile. During installation dkms modules are compiled and it fails to compile if kernel header files are missing.

I have installed the driver, yet I faced an issue that the display manager no longer works. I have tried to move to gdm3 instead of lightdm, but nothing changed. How can I solve this issue?

Hi Ash,

Welcome to our forums.

To revert to the old driver, you can remove nouveau from the blacklisted modules by removing it from /etc/modprobe.d/blacklist-nvidia-nouveau.conf the guide mentioned, and reboot, thus returning to a working display manager.

To solve the problem regarding what went wrong with the driver installation, please provide us with some details, maybe error entries related to the driver from dmesg or the display manager’s logs.

Hi,

I couldn’t succeed with debian repository so I’ve installed the driver with official nvidia package. After installation I’ve lost my notebooks monitor. On computer startup, it shows usual lines of debian booting but as soos as gnome loads it goes black with a single cursor at the top left without blinking. I can only use my external monitor and xrandr doesn’t show internal one either. nvidia settings only shows external monitor. I have msi ge75 with rtx2060. Any suggestions? I don’t wanna go back to ubuntu :slight_smile:

Hi Kerem,

Welcome to our forums.

Please provide us with some details of the issue. Do you have any related entries in your syslog?

[ 0.386514] ACPI Error: No handler for Region [EC__] (000000006762ced6) [EmbeddedControl] (20180810/evregion-132)
[ 0.386520] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20180810/exfldio-265)
[ 0.386524] ACPI Error: Method parse/execution failed _SB.PCI0.LPCB.EC._REG, AE_NOT_EXIST (20180810/psparse-516)
[ 1370.724082] ACPI Error: No handler for Region [VRTC] (000000004c65bb24) [SystemCMOS] (20180810/evregion-132)
[ 1370.724097] ACPI Error: Region SystemCMOS (ID=5) has no handler (20180810/exfldio-265)
[ 1370.724108] ACPI Error: Method parse/execution failed _SB.PCI0.LPCB.EC._Q9A, AE_NOT_EXIST (20180810/psparse-516)
[ 5000.428444] ACPI Error: No handler for Region [VRTC] (000000004c65bb24) [SystemCMOS] (20180810/evregion-132)
[ 5000.428448] ACPI Error: Region SystemCMOS (ID=5) has no handler (20180810/exfldio-265)
[ 5000.428451] ACPI Error: Method parse/execution failed _SB.PCI0.LPCB.EC._Q9A, AE_NOT_EXIST (20180810/psparse-516)

These are the only errors on dmesg.

And this is xrandr
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 608mm x 345mm
3840x2160 60.00*+ 59.94 50.00 29.97 25.00 23.98
2560x1440 59.95
1920x1080 60.00 59.94 50.00 29.97 23.98
1680x1050 59.95
1600x900 60.00
1440x900 59.89
1280x1024 75.02 60.02
1280x800 59.81
1280x720 60.00 59.94 50.00
1152x864 75.00
1024x768 75.03 70.07 60.00
800x600 75.00 72.19 60.32 56.25
720x576 50.00
720x480 59.94
640x480 75.00 72.81 59.94
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

Is there anything should I look.

Hi Kerem,

Well, not much lead to follow. Can you post your xorg.conf settings? That may bring us closer.

Hi.
I have installed the driver but now my LCD TV is unknown and i cannot get hdmi audio. With nvidia neuvou the tv ia correctly detected. Do you know what is happening?
Debian 10.3 gnome and nvidia 1060 6gb

EDIT: mea culpa, I needed to turn off secure boot in my bios settings. Everything loaded up and I have been loving my debian experience since. Very snappy, very customizable. Thanks for the great guide, everything seems to have been installed. The clue came when I saw “nvidia not running in persistence daemon” or something like that. To anyone else, if this is your first install, make sure your secure boot is disabled in bios. It’s worth trying out linux. Things certainly have changed a lot in the last fifteen years…

did not work for me. i tried every iteration, putting nouveau in blacklist, removing blacklist, whatever i do, i cannot get desktop launched again. always the same black screen on bootup, then ctr-alt f2 to log in, then try to launch startx after/before debug tries, and then xorg-server connection refused. all i want to do is run my graphics card. how can linux still be so clunky in 2020 … ? looking in the recommended log, I get the least helpful error in history: “Fatal server error: cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices.” I have spent 10 minutes on installing debian dual boot, and 10 hours trying to get the gpu to work. … … … . . …

As most instructions I found, this one is incomplete. I tried to install Debian 10 on a i7 Intel system (16GB) with a Nvidia 650 ti graphics card.

After following the instructions above the freshly (net)install won’t boot. It hangs in check disk after completion of the instructions.

I’m not allowed to put links in this post, sorry for that… I did not, but got this ‘alert box’ when I tried to post this.

After lots of trials (and hours …) this procedure worked:

And I’m not allowed to share the instructions…

Ok. It seems I can put the enhanced procedure here now.

Steps:

Enable the non-free and contrib repository.
As an administrative user open the /etc/apt/sources.list and add the non-free repository and contrib.
apt update
apt upgrade

Add Backports to sources.list
“deb. debian. org/debian buster-backports main non-free contrib” (without spaces in the link)
to sources.list and the source code line
(Edit with “Software & Updates” in Debian …)
You need this to avoid: missing firmware /lib/firmware/nvidia/gp100/acr/ucode_load.bin for module nouveau
This file /lib/firmware/nvidia/gv100/acr/ucode_load.bin is only provided by a newer version of firmware-misc-nonfree provided in the buster-backports.

Install nvidia-detect utility by execution of the below command:
apt -y install nvidia-detect

apt install nvidia-driver firmware-misc-nonfree
(or install the version that is detected with nvidia-detect)

apt install nvidia-driver firmware-misc-nonfree
(This is missing in the instruction. It will create the lib/firmware/nvidia folder with files.
apt-get -t buster-backports install firmware-misc-nonfree)

Run:
sudo apt update
sudo apt upgrade

I’m not sure if this is needed, but it worked for me:
sudo apt-get install module-assistant
sudo m-a prepare

And then:
apt install nvidia-driver

Watch Warnings. Before you reboot you should install missing components.
No warnings? Reboot the system.
In my case this worked.

1 Like