How to install RStudio on Ubuntu 20.04 Focal Fossa Linux - LinuxConfig.org

The objective is to install RStudio on Ubuntu 20.04 Focal Fossa Linux.
This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-rstudio-on-ubuntu-20-04-focal-fossa-linux

I’d suggest replacing " sudo gdebi install rstudio-1.2.5019-amd64.deb" in step 3 with " sudo gdebi rstudio-1.2.5019-amd64.deb"

thanks…this will be updated shortly

Thanks a lot! It is very helpful.

Don’t help. It’s no working

Hi! I’m getting the following error when running ‘sudo gdebi rstudio-1.3.959-amd64.deb’:
‘Failed to open the software package
The package might be corrupted or you are not allowed to open the file. Check the permissions of the file.’

(All permissions are set to Read and write).

Thanks,
-Matan

Hi Matan,

Welcome to our forums.

It may happen that the package got damaged during download. Have you tried downloading it again?

Thanks Sandmann,

I checked the sha256 sum and it’s identical to the one specified in the download page, so it’s unlikely to be a corrupt file.

Thanks again,
-Matan

Hi Matan,

To make sure you are not hitting any permissions issue, try switching to root:

$ sudo su

Then set permissions on the file to 777:

# chmod 777 rstudio-1.3.959-amd64.deb

And try to run the installation again.

Thanks! It worked :smile:

1 Like