How to install Steam client on Debian 9 Stretch Linux - LinuxConfig.org


#1
Steam is easily the most popular PC gaming client available today. Installing it on Debian Stretch is very easy, especially considering Debian is the basis for Valve's SteamOS. Steam is available in Stretch's repositories, but there are a couple of steps that you need to take in order to ensure that it works right.
This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-steam-client-on-debian-9-stretch-linux

#2

plic

Work fine, thank you for the tuto.

Config old Q9550 + 8G Ram + AMD 390x + SSD corsaire 240 G

Debian stretch driver + amdgpu driver

I tried with an AMD X1950 xtx first but the opengl failed, a more recent card was necessary.

It took me 5 minutes.

Half life installed and working


#3

Mike Sandoval

Your tutorial worked really good. Thank you so much!


#4

Krelik ATROCITY

^god-among-men^
I keep almost going back to windows, then someone makes it easy.


#5

John

Good! Thanks for sharing!


#6

KNERDY

It’s having issues. When launching Steam, i get a popup, “Fatal Error: Failed to load steamui.so”


#7

Tatyana

If problems with nVidia then

sudo apt install libgl1-glvnd-nvidia-glx:i386 libxtst6:i386 libxrandr2:i386 libglib2.0-0:i386 libgtk2.0-0:i386 libpulse0:i386 libgdk-pixbuf2.0-0:i386 libcurl4-openssl-dev:i386 libopenal1:i386 libusb-1.0-0:i386 libdbus-glib-1-2:i386 libnm-glib4:i386 libnm-util2:i386 libva-x11-1:i386 libvdpau1:i386 libbz2-1.0:i386 libglx-nvidia0:i386

If still doesn’t work then

sudo ln -s /lib/i386-linux-gnu/libudev.so.1 /lib/i386-linux-gnu/libudev.so.0


#8

Jon Groves

thanks!!


#9

Dean Eggleston

Thanks for this just what I needed!


#10

WorksFine

Works just fine for me. The other comments must not have followed the instructions very closely, are trolls, or both.


#11

KNERDY -> WorksFine

The ol’ Pot calling the Kettle Black, eh, Troll?


#12

Cristian Quagliozzi

IT DONT WORK ANYMORE


#13

Christopher Palmer

can somebody help me i am new to debian and every time i try to doetc /apt/sources.list it sais /apt no such file or directory


#14

TheWizard -> Christopher Palmer

the correct synthax is /etc/apt/sources.list
don’t forget the first " / "


#15

Jakub Sváda

Got this error so it seems not working.
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1


#16

Jim Copeland

When I run this command, I get the following error: Unable to locate package steam


#17

Beta

Confirm, Its work


#18

gwenyak

This does not works after final release of Debian Stretch (as of 2017-06-26)!


#19

zbd9 -> gwenyak

Nah, its working ! Dont post wrong informations next time.


#20

Egor

The following packages have unmet dependencies:

steam:i386 : Depends: libc6:i386 (>= 2.15) but it is not going to be installed
Depends: libstdc++6:i386 (>= 4.3) but it is not going to be installed
Depends: libx11-6:i386 but it is not going to be installed
Depends: libudev1:i386 but it is not going to be installed
Depends: libxinerama1:i386 but it is not going to be installed
Depends: libtxc-dxtn0:i386
Depends: libgl1-mesa-dri:i386 but it is not going to be installed
Depends: libgl1-mesa-glx:i386 but it is not going to be installed
Depends: libgpg-error0:i386 but it is not going to be installed
Recommends: libxss1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.