How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org


#21

I try automatic installation from PPS but it not work for me.

$ sudo add-apt-repository ppa:graphics-drivers/ppa

Fresh drivers from upstream, currently shipping Nvidia.
Current Status
Current long-lived branch release: `nvidia-410` (410.66)
Dropped support for Fermi series (https://nvidia.custhelp.com/app/answers/detail/a_id/4656)
Old long-lived branch release: `nvidia-390` (390.87)
For GF1xx GPUs use `nvidia-390` (390.87)
For G8x, G9x and GT2xx GPUs use `nvidia-340` (340.107)
For NV4x and G7x GPUs use `nvidia-304` (304.137) End-Of-Life!

$ sudo apt update

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00000F02sv00001043sd000084DCbc03sc00i00
vendor : NVIDIA Corporation
model : GF108 [GeForce GT 730]
driver : nvidia-340 - third-party free
driver : nvidia-384 - distro non-free
driver : nvidia-390 - third-party free recommended
driver : xserver-xorg-video-nouveau - distro free builtin

== cpu-microcode.py ==
driver : intel-microcode - distro free

Why I not see nvidia-410 :disappointed_relieved :?


#22

Ubuntu 18.10 and vulkan. FYI this guide is Iincomplete. Here’s what I told the ppa mantai sers of the Nvidia ppa on how to vulkan and setup vxkd to run.
sudo add-apt-repository ppa:graphics-drivers/ppa as the guide says
which will as of 18.10 auto update and refresh repositories
sudo dpkg --add-architecture i386 needed for 32 bit and wine
sudo ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
Or use graphical methid for nvidia proprietary Install
apt install --install-recommends vulkan-utils libvkd3d1 libvkd3d-utils vkd3d-demos vulkan-tools ocl-icd-libopencl1 spiriv-headers spiriv-tools
then afterword install wine from wine hq using the staging branch and winetricks
As the guide says on winehq
If you dont do all of this you will be missing 32bit libraries and the spiriv files which dxkv would not work without them. And last note do not Install bumblebee or Primus. Your graphics will then default to Nvidia and everything works


#23

Thank you very much. Installing from Ubuntu Repo worked wonders for me. :smiley:


#24

The guide works perfectly. Until I connect an external screen :frowning:
When I do this, I get the a notification (guess it is the PC’s own) that an external screen was pluged in.

But, I cannot select the monitor, neither on Gnome nor KDE.
I have seen (and tried :slight_smile:) close to 100 solutions, none of which are working.
Are there any “official” working method?
Like, can I completely disable Nvidia and use the native nouveau driver when using two monitors, or something like that.

Actually the only thing I would like is to just completely power off NVidia and just use the nouveau driver, but I cannot find any solution for doing this either.


#25

Hi Jarl Gjessing,

Welcome to our forums.

If you have desktop, the simplest way to “power off” your NVidia card is to remove it from the motherboard, which is only suitable solution with two screens if you have two ports to connect to without the video card.

Disabling the NVidia driver is sort of the same as using it in place of the nouveau driver, only the other way around: you need to remove nouveau from the blacklist, and place nvidia on the same blacklist instead.

Let me know if that works for you,
Sandmann