How to make DMA ON or OFF in ubuntu 13.10 Desktop x64


#1

Dear Sir,

I followed this command to check if dma is on or off?

sudo hdparm -d /dev/sda ENTER

OUTPUT:

HDIO_GET_DMA failed : Inappropriate ioctl for device

if above mentioned message comes, so then what to do …?

How to enable DMA Mode ON?

Please do help Sir, without making delay

Thanking you,

Warm Regards,

Basavaraj From India,


#2

Hi Basavaraj,

Your error:


[B]HDIO_GET_DMA failed : Inappropriate ioctl for device
[/B]

does not necessarily signifies that the DMA of you block device is off/disabled. Use

hdparm -i /dev/sda

to see what type of DMA or UDMA is enabled. Example:


 hdparm -i /dev/sda

/dev/sda:

 Model=SAMSUNG HD501LJ, FwRev=CR100-10, SerialNo=S0MUJ1MP723425
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=34902, SectSize=554, ECCbytes=4
 BuffType=DualPortCache, BuffSize=16384kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=976773168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: unknown:  ATA/ATAPI-3,4,5,6,7

 * signifies the current active mode

Check for “*” to see what type of DMA is enabled. In the example above the block device /dev/sda has Ultra-DMA 6 mod enabled. ( *udma6 )

Furthermore, your command ‘hdparm -d /dev/sda’ is incorrect. The general block device naming convention uses /dev/sdx for SCSI devices and hdparm’s -d option can be used only for old IDE drives. ( see hdparm man page ). This will also explain your error message !

Hope it helps

Lubos


#3

Dear Sir,

I did run the following command…

sudo hdparm -i /dev/sda ----------- Pressed Enter Button

Computer has given the Following OUTPUT…

UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6

In my Computer, Ultra-DMA 6 mode is enbled

Thanking you for giving me reply in Detailed manner. Your reply is very understanble.

Heartily Once again thankful to you Sir,

Warm Regards,

Basavaraj From India,


#4

#5