How to setup a Static IP address on Debian Linux - LinuxConfig.org


#1

Please note that for Desktop installations it is recommended to use GUI tools, such as network-manager. If you wish to configure your network interfaces directly via /etc/network/interfaces file on your Desktop, make sure you disable any other possibly interfering network configuration daemons. For example, the below commands will disable network-manager:


This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-setup-a-static-ip-address-on-debian-linux

#2

Horses Mouth

In your blog for Static IP is a working one one can follow. Only problem is ONE very crucial piece of info is missing or command i.e

# ifup eth0

Pls add so network card automatically on with static IPs under /etc/network/interfaces.d/eth0


#3

Dan

You wrote dns-nameservers … dns-nameserver


#4

Fer

Hi, thanks for the post.
I would love to know how /etc/dhcpcd.conf influences this kind of interfaces configuration.
In case everything is set up in dhcpcd.conf, is interfaces file even needed?
What is the proper and recommended way of setting both static/dhcp interfaces for both eth and wireless interfaces?


#5

Michael Jordan

Should be noted that Debian 9 with system.d uses “Predictable Interface Names,” and so my ethernet was not “eth0,” but rather “enp3s0,” which I found by calling the command “ip a” and finding it in there.

Furthermore, my /etc/networking/interfaces file had no entry for it; only the loopback. Manually adding the “allow-hotplug enp3s0” entry in it, and then creating a separate file in interfaces.d for the rest (as mentioned in this article), did the trick after a reboot.


#6

Raul Odria -> Michael Jordan

You can to modify file /etc/default/grub and add or modify the line GRUB_CMDLINE_LINUX like this:

GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"

This return the names iface eth0, eth1, wlan0 etc…