How to upgrade Debian 8 Jessie to Debian 9 Stretch - LinuxConfig.org


#1

This new release of Debian again comes with a lot more software than its predecessor jessie; the distribution includes over 15346 new packages, for a total of over 51687 packages. Most of the software in the distribution has been updated: over 29859 software packages (this is 57% of all packages in jessie). Also, a significant number of packages (over 6739, 13% of the packages in jessie) have for various reasons been removed from the distribution. SOURCE: debian.org


This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-upgrade-debian-8-jessie-to-debian-9-stretch

#2

tatoosh

Thanks for your guide!


#3

Nick

Need a bit of advise, after the final step of aptitude search ‘-o’ i have quit a few packages in the list, but wonder what the idA means in front of each row and how to remove these 'obsolete packages without breaking the new system as it seems apt-get autoremove won’t remove them.
Any help much appreciated.

plasma-dataengines-workspace - KDE Plasma data engines
plasma-scriptengine-python - Python script engine for Plasma
plasma-scriptengine-superkaramba - SuperKaramba theme support for the Plasma Workspaces
plasma-scriptengine-webkit - Web and Mac OS X dashboard widget support for Plasma
plasma-widget-folderview - plasma widget showing the content of a folder
plasma-widget-lancelot - lancelot widget for Plasma
plasma-widget-networkmanagement - Transitional package for plasma-nm
plasma-widgets-workspace - plasma widgets and containments for the KDE Plasma Workspace
python-reportbug - Python modules for interacting with bug tracking systems
python-support - automated rebuilding support for Python modules
ruby2.1 - Interpreter of object-oriented scripting language Ruby


#4

Adam Ellenbogen

Thank you. The steps above were successful for me as well. I ran into one issue where fail2ban did not start up afterwords. This seems to have been related to a duplicate port parameter in /etc/fail2ban/jail.local. I commented out the second port argument and it started working again.


#5

Milan Felix Šulc

Thanks. I’ve successfully upgraded all my servers. :+1:


#6

Tydyyt

Thanks for this article!


#7

Khup Thomte

I upgraded my linode debian server containing wp multisite. Now I could only get a blank white page on my domains. Any suggestions?
Cheers & happy new year!


#8

fjavierrsobrino -> Khup Thomte

when upgrading, you can choose if to use the config provided by the package or use the old one. It seems you have wiped your configuration by choosing the one in the package.


#9

Antonio

I’ve just upgraded my home server with jessie - xen and docker and it was flawless!

Checking the obsolete packages at the very end before the reload confused me a bit, but checking installed packages revealed that xen 4.8 was also installed and ready to assume upon boot.

dpkg -l | grep xen
...
ii xen-hypervisor-4.8-amd64

..

Thanks for the tutorial!


#10

Frederick Lim

In my Debian 8 system I have PHP 7.0 and MySQL 5.6 installed from dotdeb.

Is it OK to upgrade to Debian 9 directly? Or I have to remove PHP 7.0 and MySQL 5.6 before execute the upgrade?


#12

Cássio Rosas

Hello everyone,

I did the update by following and confirming all the steps. But I believe, it is very likely that something went unnoticed. Well when restarting the machine, the boot goes straight to a black screen and the command prompt is just like this: grub>

Is it possible to do something to recover this install?

If anyone knows and can help me, thank you.

Thanks and congratulations for the generated content.


#13

Joseph Tannenbaum -> Cássio Rosas

Super Grub? I get this every time Microsoft updates my dual boot machine with ‘Features’.


#14

G109B

No luck here with ssh access only. I followed the procedure carefully and re-checked afterwards, but it will not talk to me any more.


#15

Waldemar Biernacki

Thank you - everything went very well!


#16

RolandC

also, I’m not sure why you guys all see MariaDB everywhere… my system keeps telling me I have MySQL all over the place though


#17

RolandC

In my case, upgrading a vps with debian 8 to v9, things went fairly smoothly until I realized an issue with ssl certs prevented webmin to even start, webmin that would otherwise work properly under debian 8 and juggling with extactly the same cert files. Since my sites are all up and running and I don’t really need webmin at all, then I’ll leave as is for now…


#18

ale2014

Nice hint to search for obsolete packages. One may need two steps:

apt remove `aptitude -F %p search ‘~o’ | grep -E -v ^lib

and then libraries:

apt remove aptitude -F %p search '~o'


#19

Dennis Schulz -> ale2014

Thank you!

After it I had to run apt-get autoremove to remove the last obsolete package libcloog-isl4.
Everything seems to be ok now.


#20

Robert Klebe

I would like to raise some upgrade warnings and some notices. I have upgraded two laptops from Debian 8 to 9 since yesterday, both running themed MATE desktop, both run well after the upgrade. But:

  • Make sure you have enough disk space on the system partition. You can recover if you resize the partition and retry the upgrade though.

  • Pluma text editor: Python support for plugins does seem to be broken at the moment, so almost all plugins are now unusable (worst one is the text size plugin in my opinion). You get this error in the console when you try to enable plugins: Could not find loader `python’ for plugin [plugin name]. From now on: use another editor, bluefish maybe.

  • LibreOffice cannot open files from Samba shares. It behaves as it did in Jessie 8 - it loads, loads and loads and then dies silently. The old workaround to comment out X-GIO-NoFuse=true is not effective anymore. If you do, you’ll get this error instead: General input/output error while accessing [insert filename here]. Deleting libreoffice user folder or purging and reinstalling libreoffice-* did not help. From now on: copy-paste to and from Samba shares and open locally.

  • Classic GTK2 themes are partly (or completely) broken in MATE (1.16.2) - icons are too large, application switcher is missing graphics and possibly more. I think this has to do with the trend in MATE to drop GTK2 support. From now on: find another more modern theme, although I really liked the MacOS-X Aqua Theme.

MySQL upgraded to MariaDB without any found problems. There are no name changes for what I could see, it still runs “mysql”. It does however say MariaDB when mysql --version is executed.


#21

Robert Klebe -> Robert Klebe

I solved the LibreOffice bug mentioned in my previous post, so now it’s possible to open documents from Samba / Windows shared folders. It turns out you need to install libreoffice-gnome (sudo apt-get install libreoffice-gnome) and you shall not comment out X-GIO-NoFuse=true in /usr/share/applications/ as in Jessie 8 (if you do you’ll get the input/output error).

I suggest Kate as a replacement for Pluma while waiting for it to be updated.

  • Chromium complains about outdated Flash plugin. I have tried to disable it and uninstall it and reinstall it without luck - it continues to complain. Turns out that there’s a new version of flashplugin-nonfree in testing (buster) to solve this, for those who dare to involve testing.

  • Transparency in MATE has been off for some reason since the upgrade. I could re-enable it though, thru System -> Settings -> Appearance -> Windows -> Use software based composition (I translated the menus from Swedish). It now does real transparency - terminal transparency shows what’s behind and not only the desktop image.