How To Upgrade To Ubuntu 18.04 LTS Bionic Beaver - LinuxConfig.org


#1
The latest Ubuntu release, 18.04, marks an opportunity for both LTS users and people on the previous 17.10 release to update Ubuntu and take advantage of the latest features. Thanks to Debian's upgrade process, it should be relatively simple to either upgrade Ubuntu 16.04 to 18.04 (both LTS) or to upgrade Ubuntu 17.10 to 18.04 LTS Bionic Beaver.
This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-upgrade-to-ubuntu-18-04-lts-bionic-beaver

NOTE: SOME OF THE POSTS BELOW ARE TRANSFERRED FROM LINUXCONFIG DISQUS COMMENTS.

#2

Takahide Kohro

I upgraded from 16.04 to 18.04, largely without problems. However, the Dropbox icon is nowhere to be seen.
I get update messages of file changes, so it’s working but I cannot access the files from a Dropbox icon.
Anyone know how to fix this? Thank you in advance.


#3

Beeblebear -> Takahide Kohro

Which Dropbox Icon are you talking about?
Do you mean an Indicator icon in the Panel at the top of the desktop?
If this is the case, it is a fairly common problem at this stage.
This is due to the transition from Unity to Gnome and should be easily fixable.
First, try logging into the Gnome and then the Unity Desktop sessions and see if the problem persists across both desktop environments, then do a web search to see if anyone else is also experiencing this issue. AskUbuntu is usually a good place to look.


#4

Bogdan David Manciu

Ok so I had a 16.04, upgraded to 17.10 a while ago, now I upgraded to 18.04.

Same machine, we’re talking about a VMWare instance.
I’m getting dumped to console, no error messages to talk of.
startx gives me a gnome interface with a weird small dock on the side and no minimize button.
service gdm restart gives me a working ubuntu interface.

Already removed Xauthority +reinstall of Xorg, changed gdm custom config to Wayland=false, and now changed sources.list, but nothing seems to have helped.
How do I go about debugging this? My google fu is lacking in skill at this point.

Fixed:
Found https://askubuntu.com/questions/630058/vmware-not-starting-ubuntu

Basically reinstall gdm.

sudo apt install --reinstall gdm3

Boots into what I expect Ubuntu to look like.


#5

Joan Miquel Torres Rigo

Errata: At “Run your Ubuntu Update” section, it says: "you may also want to remove all no longer required packages using: sudo apt dist-upgrade" but it should be sudo apt-get autoremove.

On the other hand, I tried even with ‘-d’ modifier because my system continued reporting that that “no new release was found”. My system is currently 17.10.

Then I found below two posts:

  • https://askubuntu.com/questions/1028949/why-am-i-not-getting-the-ubuntu-18-04-upgrade/1028960#1028960

  • https://askubuntu.com/questions/1028949/why-am-i-not-getting-the-ubuntu-18-04-upgrade/1029863#1029863

…and checked ‘/etc/update-manager/release-upgrades’ file where in the comments I read this:

lts - Check to see if a new LTS release is available. The upgrader
will attempt to upgrade to the first LTS release available after
the currently-running one. Note that this option should not be
used if the currently-running release is not itself an LTS

release, since in that case the upgrader won’t be able to
determine if a newer release is available.

…and, saw that, in fact, I had Prompt=lts in that file.

I usually use LTSs in this computer. I upgraded to 17.10 because I knew it was last release before next
LTS and, maybe, I changed back this to “lts” to avoid forgiving it (I don’t remember).

But, the fact is that it was the actual reason because ‘do-release-upgrade’ were saying that there are
no new uptrades to me.

After changing it to “normal”, I could upgrade to 18.04.

Maybe this could be useful for someone in similar situation…


#6

Lubos Rendek Mod -> Joan Miquel Torres Rigo

Hi Joan,

Yes, on 17.10 the upgrader behavior is set to “normal” by default but thank you for pointing this out! In any case the “no new release was found” message seems to be troublesome to many users. From this reason, I have included a new section ( How To Upgrade To Ubuntu 18.04 LTS Bionic Beaver - LinuxConfig.org) to this article which is solely dedicated to this issue.

thank you for you input, it is much appreciated…!!


#7

GREECE…!!!

Thanks for the heads up.Really helped me out !


#8

Shixiang Wang

Will this purge the old softwares?


#9

Erik Nguyen

It worked totally well, thank you


#10

Thuan Pham

Thank for sharing.


#11

Tom W

Also poor timing of release info. Make sure it is available please.


#12

Praveen Gajulapalli

I’m getting this error:

Failed to lock /var/cache/apt/archives/lock

PermissionError: [Errno 1] Operation not permitted: '/etc/apt/sources.list'

Original exception was:

Traceback (most recent call last):
File "/tmp/ubuntu-release-upgrader-o1qm2vbn/bionic", line 8, in <module>
File "/tmp/ubuntu-release-upgrader-o1qm2vbn/DistUpgrade/DistUpgradeMain.py", line 238, in main
File "/tmp/ubuntu-release-upgrader-o1qm2vbn/DistUpgrade/DistUpgradeController.py", line 1949, in run
File "/tmp/ubuntu-release-upgrader-o1qm2vbn/DistUpgrade/DistUpgradeController.py", line 1913, in fullUpgrade
File "/tmp/ubuntu-release-upgrader-o1qm2vbn/DistUpgrade/DistUpgradeController.py", line 1330, in doDistUpgrade
File "/tmp/ubuntu-release-upgrader-o1qm2vbn/DistUpgrade/DistUpgradeController.py", line 1452, in abort
File "/tmp/ubuntu-release-upgrader-o1qm2vbn/DistUpgrade/sourceslist.py", line 366, in restore_backup
File "/usr/lib/python3.5/shutil.py", line 236, in copy
copymode(src, dst, follow_symlinks=follow_symlinks)
File "/usr/lib/python3.5/shutil.py", line 138, in copymode
chmod_func(dst, stat.S_IMODE(st.st_mode))
PermissionError: [Errno 1] Operation not permitted: '/etc/apt/sources.list'

Any thoughts on this one?


#13

José Cage -> Praveen Gajulapalli

I get the same error. I resolved running “sudo su” before “sudo do-release-upgrade -d” (to login as SUPER USER)


#14

Paul -> Praveen Gajulapalli

What did you type before you pressed enter and saw that error?


#15

Praveen Gajulapalli -> Paul

sudo do-release-upgrade -d

On typing the above command and pressing enter, I got this error.


#16

Zeeshan Khan

guys please wait for July end to upgrade.
Read release notes , Upgrade from 16.04 or 17.10 section

https://wiki.ubuntu.com/BionicBeaver/ReleaseNotes


#17

Paul -> Zeeshan Khan

July will be 18.04.1. If nobody updates to 18.04 then 18.04.1 won’t be as well tested. If you don’t want to update yet, that’s fine. I am updating some of my systems and will report bugs if I find any.


#18

Hermes Lorenzo Mendez

If no new release found message is present, please use this: sudo do-release-upgrade -d
in my case the upgrade process worked fine, but with linux kernel 4.15 my laptop did not boot. So I boot from linux kernel 4.13 and I have the ubuntu 18.04 running.


#19

Arancaytar

For anyone else wondering why do-release-upgrade doesn’t work yet even though 18.04 is officially released: The upgrade tool is released separately at a later time, and is downloaded from this URL:

https://changelogs.ubuntu.com/meta-release

As I’m posting this, the last entry there is still for 17.10, indicating that the 18.04 upgrade tool hasn’t been published yet.


#20

Paul -> Arancaytar

The 18.04 update tool is for updating to 18.10 and newer. When they start work on the next release, the 18.04 tool will be released and used for those testing the 18.10 pre-releases.