HP 470 g9 dual monitor dont works - HDMI-connected external monitor is not being recognized - NVIDIA

Hello, I want to use external monitor on my HP 470 g9 with newest stable Debian and proprietary NVIDIA drivers (ver. 550.78) installed. I can’t use it because my software can’t recognize my HDMI correctly.

$xrandr:
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
1920x1080 60.01*+ 59.97 59.96 59.93 40.02
1680x1050 59.95 59.88
1400x1050 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 60.02
1400x900 59.96 59.88
1280x960 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1280x800 59.99 59.97 59.81 59.91
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
700x525 59.98
800x450 59.95 59.82
640x512 60.02
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
640x400 59.88 59.98
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)

Hi Franek

What about nvidia-settings…Can you see and enable the monitor there?

Open NVIDIA X Server Settings to see if the monitor appears there. You can launch this from your applications menu or by running nvidia-settings from a terminal. If your monitor appears there, try to enable it and apply the configuration.

Anything suspicious in the log files:

dmesg | grep HDMI
and/or
dmesg | grep NVIDIA

I can’t see monitor configuration in my nvidia-settings.

#dmesg | grep HDMI:
[    5.046021] skl_hda_dsp_generic skl_hda_dsp_generic: hda_dsp_hdmi_build_controls: no PCM in topology for HDMI converter 3
[    5.062930] input: sof-hda-dsp HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input18
[    5.062958] input: sof-hda-dsp HDMI/DP,pcm=4 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input19
[    5.062985] input: sof-hda-dsp HDMI/DP,pcm=5 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input20
#dmesg | grep NVIDIA:
[    4.496308] nvidia: module license 'NVIDIA' taints kernel.
[    4.848832] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  525.147.05  Wed Oct 25 20:27:35 UTC 2023
[    4.975758] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  525.147.05  Wed Oct 25 20:21:31 UTC 2023

So far this is the only possibly concerning issue. It suggest issues with the audio part of the HDMI interface a possible driver conflict or problems due to configuration or driver installation .

See you audio configuration the check for possible issues.

Can you please provide output of:

lspci | grep -i audio
or
`lsmod | grep snd_hda_intel’

See if there is no conflicting audio driver loading. If yes, try to temporarily unload it or blacklist it. Then retest your xrandr and/or nvidia settings.

Furthermore, have you tried reload the configuration with:
xrandr --auto

BTW: how did you install nvidia drivers? Would you consider to reinstall?

$lspci | grep -i audio: 
00:1f.3 Multimedia audio controller: Intel Corporation Alder Lake PCH-P High Definition Audio Controller (rev 01)
#dmesg | grep nvidia
[    3.986201] nvidia: loading out-of-tree module taints kernel.
[    3.986207] nvidia: module license 'NVIDIA' taints kernel.
[    4.013194] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    4.150374] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
[    4.151687] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[    4.230186] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  550.78  Sun Apr 14 06:23:31 UTC 2024
[    4.259402] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    4.259405] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
[    4.842464] audit: type=1400 audit(1715427209.602:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=827 comm="apparmor_parser"
[    4.842471] audit: type=1400 audit(1715427209.602:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=827 comm="apparmor_parser"
[  149.260116] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.
[  149.279563] nvidia-uvm: Loaded the UVM driver, major device number 511.

how did you install nvidia drivers?

Using .run installer from NVIDIA website, but earlier I tried to install nvidia-detect and nvidia-driver packages from APT.

See if there is no conflicting audio driver loading. If yes, try to temporarily unload it or blacklist it. Then retest your xrandr and/or nvidia settings.

I blacklisted audio drivers and xrandr is the same.

Any chance of a faulty HDMI cable or other hardware?

Possibly try different driver versions.

On dualbooted Windows all works correctly, but I need it on Linux
And I haven’t got ubuntu, but I tried use tools shown in that video, and they’re not wprking