Install And Test Vulkan On Linux - LinuxConfig.org

Vulkan is the future of graphics on Linux. It's the next generation replacement for OpenGL, and the performance improvements are immediately apparent. Vulkan was written from the ground up to be more usable for developers, which has spawned a host of great projects that take advantage of Vulkan's potential.
This is a companion discussion topic for the original entry at https://linuxconfig.org/install-and-test-vulkan-on-linux

Argh! I followed everything, and Ubuntu seems to indicate that Vulkan is now installed, but I can not run “vulkan-smoketest” (typed from Terminal, simply says “Unrecognized command”. “vulkaninfo” responds:

What am I missing? Any help is appreciated.

Yuo should already have vulkan-utils installed.
https://launchpad.net/ubuntu/cosmic/+package/vulkan-utils

The problem was resolved long ago. The fix was to use nVidia’s own installer from the CLI.

I installed Ubuntu 18.04 on a Lenovo w520 and I followed the steps to get vulkan installed but it seems like the repository that housed vulkan no longer has it. Does anyone have a repository were I can download this from? I also couldn’t not find the nvidia driver but figured I could just use the 390 that comes with 18.04.

Had Errors at WoW (using Ubuntu & AMD) They were solved after additionally adding 386 drivers:

sudo apt install libvulkan1:i386 mesa-vulkan-drivers:i386

Thank you for the manual

1 Like

My installation run smooth, but Dota 2 start nice but crash in the middle of the game. Maybe because I have 2 GPU one AMD and one Intel. I try to disable the Intel one. Let’s see.

Try download steam, Dota 2 and enable Vulkan support on the steam launcher.

Could someone help me figure this out? I’m running Linux Mint 19.2 (based on Ubuntu 18.04) on a laptop with an AMD A8 APU (which is listed on AMD’s website as being compatible with Vulkan). Lspci lists the graphics card as a Radeon R4/R5. I’ve got all the listed Vulkan packages installed. When I run vulkaninfo, I get:

===========
VULKAN INFO

Vulkan Instance Version: 1.1.70

ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
/build/vulkan-UL09PJ/vulkan-1.1.70+dfsg1/demos/vulkaninfo.c:2700: failed with VK_ERROR_INITIALIZATION_FAILED

Any ideas how I might proceed from here? Thank you!