Installing apps etc to CentOS 8


So I have been tasked by work to setup a PC and historically they installed CentOS 6.4 but after much annoyance it seems this version isn’t compatible with the latest hardware of this PC. So I have installed CentOS 8 and am struggling to install things on it.

The instructions I have for setting version 6.4 up don’t tie up with version 8 so am struggling.

The first thing I wanted to do is install Grub Customizer and have downloaded the tar.gz from the website but when I double click on this it just unpacks it and I can’t see what I should do to install it.

The other thing I am trying to do is install Nvidia Drivers. I have disabled nouveau and it has booted in to a command line and I have logged into root and then used bash to start the nvidia installation but I get the error in the attached picture. I am now also stuck in how I get back to a proper GUI for CentOS if I can’t install the drivers.

The graphics card is an Nvidia Quadro RTX 5000 and I am trying to install these drivers

Hi AFKMatrix,

Welcome to our forums.

Do you have your kernel sources installed? You can check that without GUI, by executing the following from the command line:

$ rpm -qa | grep -E "kernel-devel|kernel-headers"

You can also verify the headers and devel version match your kernel version by printing your running kernel’s version with:

$ uname -r

Do you have a match? If not, you should install the matching packages first. If you do have the right packages, check out the logfile your printscreen mentions, and share any error messages you find in it.

Hi sandmann,

Thanks for the reply.

So I carried out your commands and got the following information:

Kernel-headers = 4.18.0-240.el8.x86_64
Kernel-devel = 4.18.0-240.el8.x86_64

And when I run the uname -r command the version does match the above.

I am reading the log file and from my limited knowledge it seems to need me to install libelf-dev, libelf-devel so will see if I can find them to install.

Thanks for the help!

So i have gotten a rpm file with the libelf-devel etc in it.

Now I copied this over to CentOS and then tried to install it using dnf. It then said it couldn’t see the mirror sites. So even thought the rpm package is sitting on the computer it is still trying to access the internet.

Anyway to stop this and just get it to use the rpm file on the PC?

There may be a situation when the package you try to install needs other packages as dependencies, in which case dnf tries to find them in the enabled repositories. You can execute the following:

# rpm -Uvh <rpm package file with full path>

Or if it is in the local directory:

# rpm -Uvh ./<rpm package file>

The “#” signs mean you need to run these commands as root. If there are dependencies, the above command will produce what packages are missing. If there are none, it will install the package.