Kdeinit error message

I set up a quicklaunch button on the taskbar and run a shell script. After the shell script successfully run I get an annoying dialog that I have to dismiss that says… kdeinit could not launch /usr/bin/xterm (or whatever I have launched). This seems to be a bug that’s been around for awhile. I am using debian latest (buster i think) and kde5. What gives? Anybody got a quick fix for this? Some silly config problem???

Hi Snookers,

It may as well be a configuration problem. What is in your quicklaunch button (.desktop file)?

It’s all real straightforward. What am I doing wrong??? The shell script does have execute permissions.

I have tried various combinations of things on the QuickLaunch configuration edit dialog, all to no avail…

Here’s my .desktop file :

[Desktop Entry]
GenericName[en_US]=do-mouse click on youtube window
GenericName=do-mouse click on youtube window

and here’s the shell script i’m launching :


export DISPLAY=:0.0
/bin/xdotool getmouselocation --shell
/bin/xdotool mousemove 2003 551
/bin/xdotool getmouselocation
/bin/xdotool click 1
/bin/xdotool mousemove 853 542
/bin/xdotool click 1

Hi Snookers,

Well the only hit that points to xterm is the following:

You might try setting that to false. Also, do you have the xterm package installed?

Uhm, no, that’s not it. Same behavior. Yes, I do have xterm installed.

This sounds like the reintroduction of an old KDE bug. Is your error dialog modal?

You could try adding some delay to the script with sleep as one of the commenters in the bug mentioned, but the next comment already states it does not work. I’d guess your kdelibs version is way over 4.2.x where this bug should be fixed, right?

hhmm sandmann,

I’m using kde5, so presumably whatever fixes from the past have migrated forward. \ \

And yes, I did see some reports that indicated this is an ancient bug, reported and “fixed” in previous

versions of linux, but I think that those fixes were never migrated across to different distributions.

And, finally, adding in a “sleep 10” does not fix the problem.

Am I going to have to look into the kdeinit source code ??? God Forbid!

your confused friend,


I just reopened bug 181477 on the KDE bugtracking website. Just fyi.


I just updated the posting on the KDE bugtracking website with the problem in the source code.

Hi Snookers,

Nice work. I’m looking forward on the ticket update from the developers.

thanks! I really appreciate the acknowledgement! I would have done more, but in order to

figure out and fix kdeinit I have to install cmake and all it’s associated madness… which I balked at :slight_smile:

Maybe someday …