Mount remote ftp directory host locally into linux filesystem -

Do you often access your ftp site to make some simple changes or your share some documents that you wish to be accessible from anywhere. You can make your access to your ftp resource easier with curlftpfs linux utility. This fantastic utility allows you to mount your ftp site to any directory withing your linux filesystem.
This is a companion discussion topic for the original entry at

Fab Kim


I want to do like that, but with sftp.
How can i modifiy this tutorial to adapt him to sftp ?


Steve Johnson -> Fab Kim

You need to add
-o ssl
after the mount point.

Eric Dubé

Adding this to fstab put my laptop in emergency mode… haven’t figured out why yet

Noorquacker Ind. -> Eric Dubé

Comment it out in your fstab, it’s being mounted too early in the boot process and is being mounted before the network has the time to start. Generally it’s not a good idea putting network locations in your fstab, unless it’s really dependable and on your local network, because if it goes out, systemd will panic as it thinks fstab drives are very important and will think that a mount failure will take the system down.

x0ex78/a45 -> Noorquacker Ind.

even with the “bg” flag?

Michael Robert Lawrence -> Noorquacker Ind.

could just add a crontab @ boot give a timer of 120 seconds to get system up etc, then mount in background…

ToyMaker San

Worked for me. I got rid of the .local at the end of the remote ip address.

Daya -chan

Sincerely I tried curlftp and it was awful D:

Jorge Manuel Hernandez

Im having problems with this command, when i mount the ftp server in my pi, the folder is converted to a “inode/x-corrupted type”, can you help me with this?

Krishan Srimal

Worked. Thanks.

I have create a cpanel account in one server with SSH enabled;
I wanted to use this FTP account for taking backup

After that I mounted this ftp space as a drive in another server with curlftpfs.
I see that ftp account /mnt/ftpaccount/ and I can copy and remove files from it;

Finally I tried to take backup with rsync to this drive /mnt/ftpaccount/ by JetBackup or also manually ( With Rsync )

I don’t aware why below error happens and how to remove this problem.

/mnt/mysb1/public_ftp/jetbackup_1_4_5dc1b629b9316d42300c6212/XXXXX/jbm.account.full/.jetbackup.index.yJDeja" failed: Operation not supported (95)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1189) [sender=3.1.3]

Would you please help me to solve this issue ?
Thank you very much

Hi Hadi_Shahidi,

Welcome to our forums.

To get more info on exactly what went wrong, you can run rsync with more verbose logging by adding the -v option, and you can further increase detailed logging with more “v” added to the first.

That being said, these kind of error messages mostly relate to different capabilities of the source and target filesystems. For example, a FAT filesystem can’t handle extended attributes of a file coming from an ext4 filesystem. If this is the case, the file should be there, only attributes will differ.


Thank you for your response

  • Mounted storage is a cpanel ftp account
  • Also I can see below error
    rsync: mkstemp “/mnt/mbk1/www/1.tar.gz.QAWR9C” failed: Operation not supported (95)

Thank you

Hi Hadi_Shahidi,

If you have access to the underlying filesystem under cpanel, you can check what type it is, and change/replace it to something that is the same or have the same featureset as the originating filesystem. If you can’t change the filesystem underneath, this will be a persistent problem.

If lost permissions are not an issue, you can use rsync with the -A --no-perms option, so permissions will not be set on the target filesystem.

Since I jumped from debian to ubuntu, it seems curlftpfs is unable to keep a connection alive long enough to use RSYNC to copy the content of a FTP.

I am getting “rsync: [sender] readdir(“XXXXXXXX”): Software caused connection abort (103)” after merely 2 seconds of launching a small script that connects both a FTP and a SMB connection to Sync them.

Any thoughts ?

Hi LouisOuellet,

Welcome to our forums.

Any other data movement works from the fuse drive apart from rsync? I’m thinking of a simple cp command or such throwing any error, or working just fine if you try to copy (and by that, read) data from the mounted curlftpfs filesystem?