NVIDIA GeForce Driver Installation on CentOS 7 Linux 64-bit - LinuxConfig.org


#1
This config describes an installation of NVIDIA GeFNVIDIA GeForce Driver on CentOS 7 Linux 64-bit.
This is a companion discussion topic for the original entry at https://linuxconfig.org/nvidia-geforce-driver-installation-on-centos-7-linux-64-bit

#2

Sarah

Hello, i followed all the steps above, but in the last step ‘reboot’, my notebook crashed in startup. My machine is Dell of line 7000, Gerforce MX 150.
If someone to solve this problem, post here please.


#3

Henrik Barestrand

I can confirm this works with scientific Linux fresh install 7.4


#4

Ahmed Riza

@ehildum, you may be in a similar position to me. Do you have both an NVIDIA card and on-board graphics? The “On no! Something has gone wrong” indicates that the NVIDIA driver installed its own version of the GLX libs which are not compatible with the on-board graphics (you can see this from /var/log/messages).

I wanted to use the NVIDIA proprietary driver for CUDA only and the on-board Intel card for graphics. In order for this to work I had to add the option “–no-opengl-files” to the NVIDIA installer.

That avoids the NVIDIA installer overwriting GLX libs that are needed by the Intel graphics. This allows the usage of CUDA with the NVIDIA driver and the on-board card for graphics.


#5

ehildum

This did not work for me.
OS: CentOS 7.3.1611 (clean installation)
Machine: ASUS Q524U laptop with GeForce 940MX graphics acceletator
After performing the steps above, the system boot hung just before it would normally display the graphical login screen. I was able to log in to a virtual terminal using Alt-F2 here. Running startx at this screen resulted in X errors indicating the nvidia driver could not find the graphics hardware. Maybe already reserved by the failed boot (???)
I then attempted reversing the Nvidia installation by 1) un-blacklisting nouveau, 2) deleting the /etc/X11/xorg.conf installed by nvidia-xconfig, 3) re-running dracut.

This resulted in the boot failing with the gui screen “Oh no! Something has gone wrong.” on both the regular boot, rescue boot, and boot with the kernel command line edited to remove rhgb and quiet options.

Not sure where to go from here, but I don’t have much invested in this installation – I’ll probably just do a clean reinstall.


#6

ukdms

Thankyou, this worked like a charm.


#7

James B

Is this method somehow better than downloading elrepo and then doing a yum install kmod-nvidia?


#8

Van

On the final step, when I reboot, It’s have some problem like that:
starting Network Manager script Dispatcher service…
[ok] started network manager scrip dispatcher service

Then I wait about 10 minutes It’s still that. What should I do, now?


#9

asanyi

I can’t detect my second display after this procedure. What can I do?


#10

TED PARKAR

I have followed the exact same steps that you mentioned. My observations are as follows:
1.) After the final reboot (per your steps) GDM fails to load and the boot process fails to proceed. takes me to the single user mode. On viewing the X11 log file it seems that the system cannot load the NVIDIA library.
2.) After running the Dracut again with the blacklist removed. The boot still fails with the same error message.
3.) Removing the xorg.conf file, the system briefly proceeds to the login screen them come out with an error message.

It appears that the install process creates some Kernel modules with is causing this to happen. I am running centos 7 on the following configuration Skylake Quad processor with NVidia 965M installed.

BTW I was successfully able to configure this on my Dell Laptop with I5 and NVS 4000M

Do you suppose there could an issue with the driver because of the processor? Any input will be greatly appreciated.


#11

Ankur Ghadiyali

i have done the steps mentioned above but now there is no display at all to my system. I think the driver package was corrupted. Please share the procedure how to roll back nouveau drivers.


#12

Lubos Rendek -> Ankur Ghadiyali

you should be able to revert by removing line ‘blacklist nouveau’ from /etc/modprobe.d/blacklist.conf and re-run the dracut command.


#13

Lubos Rendek

“#” indicates that the command must be executed with root privileges. So you need to login as root or use sudo command. This will solve your problem.


#14

Chris Offner

On

# echo 'blacklist nouveau' >> /etc/modprobe.d/blacklist.conf

I’m getting:

# bash: /etc/modprobe.d/blacklist.conf: Permission denied