Paste permissions to external HDD


#1

Hi guys, here is my scenario - when I plug in my external HDD it gets detected, my problem is that when I for instance copy some files/directory form ie, Desktop/Downloads to an external drive - when right clicking in the external HDD, paste option is greyed out, so I can’t paste anything inside my external HDD.
Any advice on what to do guys, or has someone had a similar issue and resolved?


#2

Hi,

Welcome to our forums. The paste permissions issue may be cased by multiple things. However, the most common are:

  1. you do not have a correct write (rw) permissions to a directory where the USB external disk is mounted. permission
    2.the disk is from some reason mounted as read only.

First have look at our Howto mount USB drive in Linux guide as this will help you to trouble shoot the issue.

Next, plug in your USB external drive and mount it via GUI as you normaly do. Then open terminal and use fdisk command to list all block devices. Note the difference between -1 and -l:

$ sudo fdisk -l

List through the output of the above command and find your device. The device name will be something like /dev/sdX.

next, you need to discover to which directory your USB drive is mounted. To do so take run mount command and run the output via grep using the block device name obtained earlier. For example:

$ mount | grep sdX

Using the output from the above command try to find to which directory the the USB disk is mounted to and whether is is mounted with read-write ( rw ) permissions.

One you have the directory name check for the permissions with ls command:

$ ls -ld /usb/directory/name

Check the permissions and use chmod/chown command to correct any issues that is granting you write and executable permissions to this directory.

The below image should give you some clues on what has been discussed above. Please note that the name of your USB block device may be different:

Hope this helps…

Lubos


#3

Hi Lubos,
Thanks for taking your time to look into this - I followed the instructions on the video and tried changing the permissions of the directory, but there’s still no luck as when changing the permissions gives me operation not permitted. when following the video, I get to unmount step without any problems, but when running “mount | grep sdc1” I see that my /dev/sdc1 now becomes available on /media/user/VERBATIM

So I still cannot copy anything from GUI to external HDD
Am I missing anything?


#4

Hi Lucas,

Can you post the output of the mount command while the external HDD is connected? Your distribution and it’s version may also be useful.

And another question: does the HDD works fine with other devices?


#5

Hello,

As suggested by @sandmann it would be helpful if you provide us with some additional information by copy and pasted the output of the mount command and fdisk -l command.

Have you tried change the permissions of /media/user/VERBATIM directory as:

$ sudo chmod 777 /media/user/VERBATIM

to see if it helps. May not be a proper/permanent solution but it may narrow down the possible issues.

Lubos