Please don’t recommend oibaf PPA for ubuntu

After reading one of your page about improve-your-wine-gaming-on-linux-with-dxvk, I’ve tried oibaf PPA because you recommend it “as a great PPA”.

After tried it I have many problems, like firefox and thunderbird broken. :exploding_head:
After searching many times (1 month) in many forums, I finally discovered this PPA is know to cause many issues.
This is serious because in my case (and not only me), it is impossible to purge the PPA via ppa-purge. :cold_sweat:
Using this PPA can seriously break the system.
Please update the page linked above and warn users of this danger.
Thank you.

ppa-purge is deprecated in Ubuntu version 20+. Instead, use sudo add-apt-repository with the -r option added at the tail/end of the command. For instance, if you wish to remove the oibaf repository, then run:

sudo add-apt-repository ppa:oibaf/graphics-drivers -r
1 Like

The article in question was published on 2020-06-06 i.e. 2+ years ago.

As mentioned at the oibaf’s PPA page, oibaf is currently supported only on Ubuntu versions 22.04 (jammy) and 22.10 (kinetic): Ubuntu versions 20.04 (focal) and 21.10 (impish) are not supported anymore.

You didn’t mention if you’re using Ubuntu, neither the version of your (presumed) Ubuntu distro. If you’re using neither Ubuntu version 22.04 nor 22.10, then oibaf is not supported and this may be the reason why you experienced issues.

If you however are using either Ubuntu version 22.04 or 22.10, you may want to report the issue to the developer at the project’s forum.

Ok, but I think you should warn on the page anyway.

I didn’t write that article… :grin:

…but I don’t blame the publisher of the article, either, because it’s hard to keep articles up-to-date and it’s impossible for an article to cover literally everything that can go wrong with everyone applying the article’s content.

Each user uses a different computer (i.e. a different hardware), with a different Linux distribution of a different version, a different kernel version etc. Even the architecture may be different: some people may still be running a 32-bit Linux kernel instead of a 64-bit one.

Maybe a big, red :stop_sign: (or yellow :warning:), automatic tag could show up at the top of the article when its release date became more than 1 year old, alerting readers that the article is more than 1 year old and, therefore, its content may be outdated…

Even so, it’s always expected that those reading the article take the matter at hand and make sure that all the resources provided at the article are fit to such user’s hardware and software. I mean: don’t just install everything mentioned in the article and expect everything to magically work. Take a look at the PPA (like I did prior to writing about it, here), make sure that your system version is supported and make sure that you know how to undo things that eventually don’t work as you expected when you did them.

Moreover, that article is not about installing oibaf: it’s about installing DXVK. It just mentions oibaf as a great PPA (i.e. an optional install) that you may add to get the absolute latest version of Mesa possible. Installing oibaf is not a requirement, and installing the latest version of oibaf may be problematic for some Linux kernels. In other words, you may:

  1. Decide to not use oibaf (i.e. keep the MESA drivers that originally shipped with your system); or
  2. Add the oibaf PPA and then install a different Linux kernel whose version works with the drivers installed by such PPA. Canonical provides hundreds of alternative kernels that you can download and install, if you want to try them and know how to do it; or
  3. Add a different PPA that also upgrades MESA, like e.g. kisak-mesa or kisak-mesa-stable: the first one (kisak-mesa) provides mainline (i.e. more up-to-date but less compatible) MESA drivers, the second one (kisak-mesa-stable) provides MESA drivers that are likely older and less efficient but more stable and compatible than those provided by kisak-mesa.

If you happen to decide that you want to try the PPAs that I mentioned as an example, I believe that you should start with kisak-mesa: if it causes any issue, you can then remove the kisak-mesa PPA and then add the stable one (kisak-mesa-stable). By doing so, either you’re going to get the more up-to-date MESA drivers (kisak-mesa), or you will at least get the most up-to-date MESA drivers that don’t break your Linux distro.

If you try those PPAs and all of them break things, remove those PPAs with add-apt-repository -r and then reinstall the MESA drivers. You have to know your hardware, too. For instance: if the maker of your native GPU (graphics processing unit a.k.a. graphics card) is Intel, then you have to install a native driver such as mesa-va-drivers (the name may be different depending on which Linux distribution and version you are using), but if the maker of your native GPU is Nvidia, then the name of the native MESA driver is likely mesa-vdpau-drivers or somethig similar to this.

Other possible names of packaged MESA drivers and libraries that you’ll have to reinstall are:

  • libegl-mesa0
  • libgl1-mesa-dri
  • libglapi-mesa
  • libglu1-mesa
  • libglx-mesa0
  • mesa-vulkan-drivers

It’s also recommended to have mesa-utils installed.

Linux sometimes is try and error. :four_leaf_clover: This is the case with different versions of the MESA drivers.


I said “you” because we are in “Site Feedback / Suggestions”.
I still think all you write should be put in the article!

I insist because the special thing with oibaf ppa is the potential difficulty to remove it and get back to previous state. The command you gives don’t work for me, I’m still with plenty of package in oibaf version after running it.
But I’m not looking for support here (not the good section anyway).

I just warn that I’m not the only one having problems with that ppa, it’s a know problem so the article, because it’s online, should be edited.

Thanks anyway for your help!


Are you using Ubuntu? If you are, you can remove these packages by following these steps:

  1. Press CtrlAltT to open a new terminal (i.e. shell emulator) window.

  2. Select this command:

    sudo apt install synaptic apt-xapian-index -y ; sudo update-apt-xapian-index ; sudo synaptic
  3. Press CtrlC to copy it.

  4. Click on the shell terminal window and then press CtrlShiftV to paste the command into the shell terminal window.

  5. Press Enter, then type your password and press Enter again.

  6. Synaptic will be downloaded, installed and then executed. Synaptic is a frontend (i.e. a Graphical User Interface – GUI) for the apt program: it shows you all packages available in the repositories that were added to your Linux distribution. It also shows which packages are installed, lets you install and uninstall packages etc.

  7. Now at the open Synaptic window, click on the Search :mag: button. A pop-up window titled Find will show up. At its Look in: field, select Version, then at the Search: field, type oibaf and then click on the Search button.

  8. Synaptic will then show you a list of all DEB packages in your added repositories whose version name/number contains the word oibaf in it. The ones that are installed will show up with a marked checkbox :white_check_mark: at the left column S.

  9. Right click on the first installed oibaf package at the top of the list and then click on Mark for complete removal. Repeat this very same procedure for each one of the oibaf packages that are installed. If Synaptic asks you if you want to mark additional packages for removal along with the oibaf one that you mark, click on Mark.

  10. Once you’re done selecting all oibaf packages, click on the Apply :leftwards_arrow_with_hook: button at the main window.

  11. When Synaptic finishes removing the oibaf packages, close/exit Synaptic, return to the shell terminal window and then execute the command below (by selecting it, then copying it with CtrlC, then pasting it with CtrlShiftV, and then pressing Enter):

    sudo rm /etc/apt/sources.list.d/*oibaf*.*list*
  12. Furthermore, select and copy the command below, then paste and execute it at the shell terminal window (this one is going to update your apt list of available packages from the available repositories, but it will also automatically remove unecessary packages previously added by oibaf, and will then clean the cache so old oibaf packages aren’t reinstalled by accident):

    sudo apt-get update ; sudo apt-get check ; sudo apt-get dist-upgrade -y ; sudo apt-get autoremove -y ; sudo apt-get clean
  13. Once everything is done, reboot your system or run one of these commands at the shell terminal window:

    telinit 6




    init 6
  14. Once you’re back from reboot, your system shall be running the original MESA drivers from your Ubuntu distribution.


The command sudo add-apt-repository ppa:oibaf/graphics-drivers -r does not uninstall any oibaf package: it just removes the oibaf PPA (repository) from your system.

When you execute an installation command such as sudo apt install mousepad, you’re basically asking Ubuntu to take a look into all the repositories that are added to your system, in an attempt to find the mousepad package:

  • If none of those repositories have a package named mousepad, then apt informs you that no such package is available.

  • If only 1 repository has a package named mousepad, then apt checks if such package’s version is compatible with your Ubuntu version: if it is, apt installs it, otherwise it doesnt install it.

  • If 2 or more repositories added to your Ubuntu have the mousepad package, then apt sees which one has the newest mousepad version which is compatible with your Ubuntu version, then downloads such mousepad from such repository and installs it.

So, you see, when you added the oibaf repository to your Ubuntu system, you did not install any oibaf package: you just “told” your Ubuntu system that oibaf contains some packages, so Ubuntu makes apt look into such oibaf repository every time that apt searches for a package to be downloaded and installed.

But then you “told” apt to install some packages that are available at the oibaf repository, and because the oibaf repository packages are of a newer version than in the other repositories, apt downloaded and installed such packages from the oibaf repository.

Then I let you know about the command sudo add-apt-repository ppa:oibaf/graphics-drivers -r, which removes the oibaf repository from your Ubuntu system. However, all oibaf packages already installed remained installed.

My last post before this one explains how to use Synaptic to uninstall all the oibaf packages that you previously installed. By doing so after running sudo add-apt-repository ppa:oibaf/graphics-drivers -r, you pretty much undo everything that you did when you added the oibaf repository and installed its packages.

Ok, got it. Well, I posted a couple of very long step-by-step procedures which I hope are going to help you sort this issue out for good. Hope it works for you! :nerd_face: :crossed_fingers:t2:

Hi all!

At first I want to say here a big THANKS for all this super useful information. This really helped me to get rid of an old and outdated oibaf PPA installation in conjunction with Kubuntu 20.04 LTS.

The above given information solved the problem for me but I should add here most likely some additional important stuff.

Keep a BIG attention when removing the oibaf files through synaptic. As far I remember, I correctly followed the instructions but when I clicked on the Apply :leftwards_arrow_with_hook: button I got an error message. Then I simply tried it again and at the second time it started to remove the files. Shortly after that I realized that for whatever reason the whole process took much longer then expected. I also saw that there were much more files removed then just the oibaf ones. :astonished:

In the end it turned out that the whole KDE plasma desktop was also uninstalled. As a result, I had after a reboot no longer any GUI available, it always booted to the console. This was not so grave, because it was still possible to login with username and password. And I had also still internet access via network cable (aka LAN). But the solution was actually quite simple, - the desktop environment had to be reinstalled.

So, when you are on Kubuntu then just perform:

sudo apt-get install --reinstall kubuntu-desktop

Or alternatively, when you are on Ubuntu:

sudo apt-get install --reinstall ubuntu-desktop

This should reinstall all default packages. To some degree this does act like a “repair installation” on Windows. I didn’t know that those arguments exists. This was really helpful in that situation. :+1:

Unfortunately I tried first an other approach. I had the glorious idea to make a distro upgrade from CLI. So I purged all remaining third-party PPAs with ppa-purge and started the upgrade process to Kubuntu 22.04 LTS.

The upgrade process worked but a release upgrade is not a reinstall. So I ended up again at the console. And this time I had for whatever reason no Internet access. So the whole situation was even worse. :disappointed: After a more closely look I saw that the Ubuntu “Network Manager” was not installed. I download the needed files at an other computer and then I installed them manually:

sudo dpkg -i network-manager_1.36.4-2ubuntu1_amd64.deb libbluetooth3_5.64-0ubuntu1_amd64.deb glib0_1.18.6-1_amd64.deb libndp0_1.8-0ubuntu3_amd64.deb libnm0_1.36.4-2ubuntu1_amd64.deb libteamdctl0_1.31-1build2_amd64.deb

Additionally I installed also ifconfig with:

sudo dpkg -i net-tools_1.60+git20181103.0eebece-1ubuntu5_amd64.deb

To my great relief this was enough to get it again working. After a reboot to the console I had again Internet access. :smiley:

Finally, I applied then the above mentioned reinstall command of the kubuntu-desktop. This reinstalled the whole GUI while preserving all settings and configs. So after a new reboot everything was again exactly on its place, nothing got lost.

And by the way, the oibaf PPA can be absolutely recommended. It is a GREAT possibility to get the newest Mesa builds. It provides you with the latest functionality and compatibility regarding any graphics card. But yeah, the end-user must give attention to the fact when it becomes EOL. It is the sole responsibility of the end-user to look about that. That should be clear from the beginning.

I wasn’t aware of the fact that it is quite complicated to uninstall that PPA when the Ubuntu release is no longer supported and all corresponding files are deleted from the PPA.

Whatever, I have learned again A LOT! And that’s the nice part of that little adventure. :wink:

1 Like

Sorry to hear that this happened to you. This indeed may happen if the previously installed deb has a control file that declares a lot of dependencies and then APT (mistakenly) understands that, if such deb is removed, then all its dependencies are no longer needed and can be removed.

This command shows you what APT did in the current month:

cat /var/log/apt/history.log

…so if APT (by itself or through Synaptic or another frontend) removes more packages than it should, you can see in such log which packages were mistakenly uninstalled and then just install them back.