Problem with live-installer and Hyperborea


#1

Hi,
first at all, thanks for your great job concerning Doudou Linux, my son is really enjoying it (and me too :-)).

Last week-end, I tried to install Hyperborea but I had a problem. I create a live usb disk (because the computer DVD seems to be broken) and I boot it without any problem.

I open a Linux terminal and, following your manual, I run a “sudo live-installer” to install on the internal computer’s hard disk. The process runs perfectly until the end.

So, I reboot the computer and boot the hard disk but the distro freezes on the boot screen.

I try to boot in debug mode and an error message is displayed. The distro wants to enter maintenance mode because root partition (/dev/sda1) seems to be corrupted (the distro tries to re-mount read-only the partition but can’t) and asks for a fsck.

I retry the process a second time (live-installer from the bootable usb key) but the problem still remains.

Rebooting from the live usb key, I run a “fsck /dev/sda1” to correct the problem (it fixes a wrong superblock allocation). So, I reboot from the hard disk but I still have a partition corruption problem (not at the same point).

At last, I try to install on an usb key instead of my hard disk but the same problem appears (/dev/sda1 corruption).

Have you alreary heard of such problems ?

Best regards,
Franck.


#2

Hi,

Thanks you for the interest into our project :). I’m sorry, I must say I’ve never heard of such problems.

If the master USB key was containing disk errors, the installer would surely had problems while trying to copy files onto disk. Moreover, as it is only performing file copy, there is no reason for the destination superblock to be wrong. To me it sounds like an issue with the program responsible for disk formatting (parted), but I can’t tell what. You can try to reformat your disk manually and deactivate formatting in the installer if it is possible.