RSnapshot Networking Help


#1

Hi, I have two Ubuntu Servers 18.04 that are both on the same hardwired network LAN.
Server names are Ubuntu and Ubuntu1. Both can see each other using the Places, Home Folder GIU.

Using Rsnapshot I want to run incremental backups of a directory on Ubuntu to a backup directory on Ubuntu1.

Can anybody help me with the ‘Backup’ line of script required in ‘rsnapshot.config’?

I have tried ‘backup ssh:ubuntu/server/reportfiles/ ubuntu/’ and about a million other variants to no avail.


#2

Hi Richard,
Thank you for using our forum.
Can you provide us with a screenshot of some of your attempts?

Can you confirm rsync is installed on both systems or they can ssh each other?

Thank you.


#3

Hi Richard,

any specific errors you are receiving?

Also you may find the following guide to rsnapshot and incremental backups on Linux useful.

Lubos


#4

Hi Fabek
Thanks for your interest.
Yes rsync is installed on both systems and they can ssh each other.
A screen shot from the server I want to run backups from is attached and shows a failed attempt. It also shows where my source files for backups are located smb://ubuntu/server…
I need the ‘backup’ syntax line in rsnapshot.config for the program to find my source files ie TardisWeb
Any help will be much appreciated, Cheers Richard


#5

Hi Lubos
Thank you for your offer to help.

I have just done a reply to Fabek that answers his questions and covers yours. Please feel free to add to the conversation. If you cannot see it let me know and I will send it directly to you.

I had a look at your link to the rsnapshot help page and was not successful in solving my problem.

Cheers, Richard


#6

Hi Richard,
can you please run the below command and give us the output?

cat /etc/rsnapshot.conf | egrep -v "^#|^$"

Thank you.


#7

!

Cheers


#8

2 of 6


#9

3of6


#10

4 of 6


#11

5 of 6


#12

6 of 6

Cheers Richard


#13

Hi Richard,
can you run also this command :slight_smile:

rsnapshot configtest

and give us the output?

Thank you.


#14

Hi Fabrizo

Thanks for staying interested.

‘rsnapshot configtest’ returns a single line of ‘Syntax OK’

‘rsnapshot -t daily’ returns 8 lines of text, none of which show any errors.

‘rsnapshot daily’ runs a full backup without error creating the directory ‘daily 0’ in the correct location.

If I run ‘rsnapshot daily’ again it runs an incremental backup without error creating the directory ‘daily 1’ in the correct location.

But the sub directories are as per my ‘backup’ line in rsnapshot config and not what I want, nor are they accessible to staff on the wider network.

Rsnapshot also does not run automatically each day or week.

Cheers Richard