Steam Gaming System

I have tried dozens of ways to install Steam on my new System76 Ubuntu 18.04.2 system and they all fail.

The application never launches. Pushing the buttons or waiting for the popup never work.

Hi Gregory,

Welcome to our forums.

Please review our general guidelines on how to ask for help, and provide some more information we can start on.
How did you tried to install Steam? Where there any error messages? If so, what where they? What button you push does not work?

Also, executing the Steam application from a command line terminal using the steam command should provide you with an additional information on why the steam application does not start. Copy and paste the error here so we can provide you with a further help.

Furthermore make sure that I have installed appropriate drivers for your graphic:

Here is the message.

Running Steam on ubuntu 18.04 64-bit

STEAM_RUNTIME is enabled automatically

Pins up-to-date!

Installing breakpad exception handler for appid(steam)/version(0)

libGL error: No matching fbConfigs or visuals found

libGL error: failed to load driver: swrast

Sometimes I've had these errors and sometimes I haven't and it ends

at Pins up-to-date!


Hi Gregory,

What type of video card do you have? Please post the output of the following:

$ sudo lshw -C video

That way we can see the card and the driver associated.

Here is the output:


       description: VGA compatible controller

       product: NVIDIA Corporation

       vendor: NVIDIA Corporation

       physical id: 0

       bus info:        version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master
cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:187 memory:dd000000-ddffffff
memory:90000000-9fffffff memory:a0000000-a1ffffff
ioport:e000(size=128) memory:c0000-dffff

As stated above. Can confirm that your NVIDIA drivers are properly installed? In not, install Nvidia drivers and try the steam command again.