Tor Browser Install Issues - Ubuntu

With Windows 7 going the way of the Dodo bird, I started switching to Ubuntu 18.04 Bionic Beaver on my laptop. I’ve had no problems that I know of to this point, except installing Tor Browser.

I’ve followed directions on many different sites with no luck. I get to the point where I have the 2 icons: Tor Browser & Tor Browser settings.

I click on settings, it loads for a bit, then I get the message it can’t validate signature or I may be under attack.

Any tips or advice on this sure would help, I’m lost.

Thank You

Hi I’m having the same issues. It appears that the issue is related to GPG as I was unable to start tor browser where gpg hangs with refreshing keys message.

However, I was able to install the Tor browser on Ubuntu 18.04 manually.

I will need to update the above article but for now try this:

First, download the tor package and sig file. Next, Import TOR GPG keys:

$ gpg --auto-key-locate nodefault,wkd --locate-keys torbrowser@torproject.org

Next, verify the downloaded package. Please note that your tor version might be different so update the command with appropriate version:

$ gpg --verify tor-browser-linux64-9.0.2_en-US.tar.xz.asc tor-browser-linux64-9.0.2_en-US.tar.xz
gpg: Signature made Tue 03 Dec 2019 05:50:28 AEDT
gpg:                using RSA key EB774491D9FF06E2
gpg: Good signature from "Tor Browser Developers (signing key) <torbrowser@torproject.org>" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: EF6E 286D DA85 EA2A 4BA7  DE68 4E2C 6E87 9329 8290
     Subkey fingerprint: 1107 75B5 D101 FB36 BC6C  911B EB77 4491 D9FF 06E2
linuxconfig@linuxconfig-org:~$ tar xJpf tor-browser-linux64-9.0.2_en-US.tar.xz

Extract the tarball:

$ tar xJpf tor-browser-linux64-9.0.2_en-US.tar.xz

and simply run the Tor browser from terminal. I recommend to start Tor from the terminal at least for a first time so you might be able to see possible error messages etc. ( if any ):

$ cd tor-browser_en-US/
$ ./start-tor-browser.desktop

Hope this helps…

Lubos

Thank You for the quick response. I bet I tried to install Tor 30 times in the past 3 days. I’ll give it a try in the morning, get a fresh start.

One more quick question for you. In step 2, with the multiple commands, do I do it as a batch command, the whole thing at once? Or command by command? That is one thing I’ve never completely understood. I’ve tried both ways, thinking that may be causing my issue, but it never resolved anything.

I’ve tried to Google that question, but never got a clear answer.

Thanks again,

Larry

Hi Larry,

Here are the two most common documentation conventions when working with Linux command line:

  1. $ --> execute command as a regular user
  2. # --> execute command with administrative privileges

Hence each $ or # denotes a single command. From here you have two alternatives. First, execute the all commands one by one or create bash shell script ( which is an overkill in this instance ) to execute all commands in batch.

The following two guides will provide you with an easy way to Linux command line and bash scripting. Spending some time with both guides is defintely time well spend. It will provide you with a solid working knowledge and understanding of GNU/Linux as you will be able to work with any GNU/Linux distro and any GUI.

Again, Thank You.

I’m still bashing my head against a wall though.

I enter:

[quote=“Lubos, post:2, topic:3786”]
gpg
[/quote] ( I can’t post the link being new )

And get a permission denied error. I’m still in a learning phase, but not giving up. Eventually I’ll figure it out, or drive everyone here crazy asking stupid questions.

Why can’t it just be a simple fix.

Can you please paste here the output of the following command:

$ ls -ld ~/.gnupg

Make sure that this directory is own by your user.

I’m going to try to post step by step screen shots, if it doesn’t take up too much space. That may work better.

A couple questions first though, as I might be messing up this way.

Do I need to create a folder named Tor or Tor Browser or something like that? Or does Ubuntu do that?

Do I need to extract the download? Or leave it as-is?

I keep reading I need to download the .asc file, that I can’t find anywhere.

I hope I present this well. It should show as far as I can get before errors arise.

My System:

I just got the Memo on only being able to post 1 image per post…

Sorry for a late response. I thought it would be easier to make you a video on how to install tor on Ubuntu 18.04 / 20.04 from the official Tor Project packages:

Below you can find my notes so it should be simple copy and paste. Please note that you only need to make sure that the Tor version is up to date as the below commands are for Tor 9.0.3.

DOWNLOAD FROM:
https://www.torproject.org/download/languages/

$ wget https://www.torproject.org/dist/torbrowser/9.0.3/tor-browser-linux64-9.0.3_en-US.tar.xz
$ wget https://www.torproject.org/dist/torbrowser/9.0.3/tor-browser-linux64-9.0.3_en-US.tar.xz.asc

IMPORT KEYS ( be patient here, this may take some time ):
$ gpg --auto-key-locate nodefault,wkd --locate-keys torbrowser@torproject.org

VERIFY ( optional but recommended ):
$ gpg --verify tor-browser-linux64-9.0.3_en-US.tar.xz.asc tor-browser-linux64-9.0.3_en-US.tar.xz

EXTRACT:
$ tar xJpf tor-browser-linux64-9.0.3_en-US.tar.xz

RUN:
$ cd tor-browser_en-US/
$ ./start-tor-browser.desktop

In case you encounter some issues please let us know and be specific on what and when went wrong.

hope this helps

Lubos

Thank You. I did get up to where it asks that I connect/Configure, at that point I encountered the following"

Any help on this will be appreciated. There isn’t much to configure if I click that option

Try click on the copy tor log and paste it here.

I’ll try to, I see 4 different logs, but I don’t see an option to save them. Give me a hint? And Thank You

You could try to select (CTRL+A), then copy-paste the logs into a text editor like gedit. Which in turn gives you the option to save them to a file.

I tried several times, I got several warnings:

I can’t post a text file

I’m limited to 32,000 characters

I can’t post links, Somewhere in the log there must be a link.

Any suggestions?

Do you see any relevant error messages in the logs? You could paste those. You can also sanitize the logs with gedit feature “search and replace”, by replacing :// with a neutral character that hits the human eye but does not provide a valid URL, like “xXx”.

I did get Tor Running, Thanks to both of you for your help.

That created a new problem, I doubt TOR had anything to do with it. But now I get an error when checking for updates. I’m told I need to refresh the software cache, when I do…it Freezes/Stalls. I can’t do anything but reboot.

I am getting closer though, I think.

Please create new thread and describe your issue in more detail.

thank you