Trying to rid myself of Gnome after 18.04 upgrade


#1

Hi,

Upgraded from 16.04 to 18.04 but I really don’t like the Gnome environment. Sought advice via best things to do after installing 18.04 and followed the instructions to put the Mate desktop in its place. The problem started when I wasn’t presented with the option to select lightdm as the boot selection. When I boot the Mate logo appears but it still shows the Gnome desktop. I’ve tried to get it to change but it has resisted my efforts.

What I see on start up now is:

Error found when loading /etc/profile:
;line


#2

Hi Tommo,

First make sure that the lightdm is installed on your system. Most likely it is already hence the lack of the select option during the Mate desktop installation. To do so run:

$ sudo apt install lightdm

If it is already installed than attempt to reconfigure it in order to make lightdm as a default display manager:

$ sudo dpkg-reconfigure lightdm

This will ask you to choose your default display manager. Select lightdm:

Confirm that lightdm is selected as default:

$ cat /etc/X11/default-display-manager
/usr/sbin/lightdm

The easiest now is to simply reboot and make sure that you select MATE desktop as a default desktop environment:


Hope this helps…

Lubos


#3

Hi Lubos,

I did have lightdm installed but went through the motions as per the above. Had a message on the last line to say it wasn’t a valid directory, rebooted but still with the cursed Gnome! I just wish I’d stayed with 16.04


#4

Any other information you can provide would be helpful. What error message, can you please paste it here or include screenshot? Can you check your log files like /var/log/Xorg.0.log for any suspicious error messages?

Did you confirm that lightdm is selected as a default display manager?

$ cat /etc/X11/default-display-manager
/usr/sbin/lightdm

#5

Go to the Gnome settings and customize it.