Ubuntu 20.04.3 LTS - power off button - problem turn off

I have 20.04.3 upgraded from 20.04.1 and problem still exists:

When i click “power off” > “power off” > and confirm, after pressing the button the shutdown procedure don’t start - i can wait and nothing. Next i click again power off and confirm and later it works and shutdown correctly.

The problem does not occur often, rather 2-3 times (out of 7) a week.

/var/log/syslog logs from example problem:


Sep  2 12:40:42 pw systemd[1]: Finished Ubuntu Advantage APT and MOTD Messages.
Sep  2 12:42:25 pw kernel: [ 2921.326768] pcieport 0000:00:1c.4: AER: Corrected error received: 0000:00:1c.4
Sep  2 12:42:25 pw kernel: [ 2921.326781] pcieport 0000:00:1c.4: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
Sep  2 12:42:25 pw kernel: [ 2921.326783] pcieport 0000:00:1c.4:   device [8086:9d14] error status/mask=00000001/00002000
Sep  2 12:42:25 pw kernel: [ 2921.326784] pcieport 0000:00:1c.4:    [ 0] RxErr                 
Sep  2 12:42:31 pw kernel: [ 2927.324405] pcieport 0000:00:1c.4: AER: Corrected error received: 0000:00:1c.4
Sep  2 12:42:31 pw kernel: [ 2927.324415] pcieport 0000:00:1c.4: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
Sep  2 12:42:31 pw kernel: [ 2927.324417] pcieport 0000:00:1c.4:   device [8086:9d14] error status/mask=00000001/00002000
Sep  2 12:42:31 pw kernel: [ 2927.324419] pcieport 0000:00:1c.4:    [ 0] RxErr

Hi Softwareman,

Welcome to our forums.

A strange issue you got there. I assume a shutdown -h now from the console would work every time, right? If so, the problem should be somewhere in the GUI layer. Does the console way work?

yes console work correctly, but the GUI doesn’t :confused:

I searched around a bit about the error messages you got, and it seems those aren’t relevant to the issue at hand.

Do you use the default Gnome desktop, or something else? Did you do any changes to the desktop environment? I’m thinking of advanced settings, not new background or shortcuts.

No, i didn’t make any specific changes, I read somewhere that new kernel updates should to resolve this problem but it didn’t.