Ubuntu 20.04 Remote Desktop Access from Windows 10 - LinuxConfig.org

Greetings.

I followed the instructions and I am stuck on XDRP login screen.
It says:

Connecting to sesman IP 127.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait
login failed for display 0

I am confident that I entered my correct credentials.

Please advice.

I think you have the wrong port in the tutorial port 3389 is used. I guess you have to correct that in your Remote Desktop Connection settings.
Since I am using a Xubuntu client with Remina to establish the remote connection I can’t help you there.

This worked perfectly for me!

Hi all, thanks for the guidance - Linux newbie here. I got as far as Step 6 and was greeted by Windows RDP with - “RD can’t connect to the remote for either 1) Remote access to server not enabled, 2) Remote computer turned off, or 3) Remote computer not on network. Make sure of 2 and 3 and remote access is enabled.” I have no idea whether or how Remote Acces is enabled on my Zorin (Ubuntu?) system.
Any suggestions? TIA

Hi GeoffWhere,

Welcome to our forums.

I would suggest testing the remote machine’s port you are trying to connect to. With this step you can ensure that you reach the remote machine on the network, and it is listening on the port you try to connect to. I would do something like:

telnet <remore-machine-name-or-IP-address> 3389

Where 3389 is the default TCP port for RDP session, and it is the one you opened at step 3.

Dear Sandmann, thank you for stepping in, much appreciated.
Here’s what I did:
Open terminal
user@system_name:-$ telnet 192.168.xxx.xxx 3389
Trying 192.168.XXX.XXX …
Connected to 192.168.XX.XXX.
Escape character is ‘^]’

No further response - where do i go from here?

As you may be able to determine from my request and from the above, I’m quite at sea here and have no idea what I’m doing with regard to this. What i find most puzzling is that Windows Fiile Manager shows the Zorin machine as a network share but I cant view the files in the share folder.

In another vein, I have 2 HDDs installed, one is system drive (sdb) the other is the HDD I want to use as my share storage (sdb1), apparently owned by root. How do I allocate that drive to my user ownership, or is that unnecessary?

You should run this telnet command from the machine you would like to reach the remote session from - I assume that’s the Windows machine, not the Zorin one.

About your other question, there is something amiss here. Your primary HDD drive may be sdb, but the other one can’t be sdb1, because sdb1 stands for the first partition of the sdb drive. Apart from that, you really don’t need to change a drive’s (device’s) permissions - to use the space on it as a normal user, you need to create a filesystem on it (if there is not one on it already), mount the filesystem, and give permissions within the filesystem to your normal user - on directories, files, whatever it needs to access.

Thanks for that update re Telnet,
I’ve enabled Telnet on my Windows 10 system and the result from this test was that Telnet just seems to hang, no response. I don’t know whether/how to configure the Gufw Firewall on the Zorin side (I’ve had it rurned off prior to this) but after enabling it I notice a rule to allow 3389 in for tcp & tcp(V6), but still no connection at either desktop.

  • I have 3 systems on this LAN:
  • 1x Windows 10 office system (Outlook, Word, P’point, etc.);
  • 1x FreeNAS/Plex Server;
  • 1x Zorin system that will become my MIDI plaything and, with its 4TB HDD, another backup layer to FreeNAS Snapshots and the 2x legacy retail-class NAS drives that backup my office system.

My goal is this: I want to be able to occasionally share files between the 3 systems but primarily to manage the backups as above, as well as use the FreeNAS system for media storage and to host Plex Server across the LAN. As such, I need those systems to be interconnected and accesible from both Zorin and Windows systems (FreeNAS can operate in the background, no need for shell level access, except form the Windows/Zorin desktop File Manager).
In my futile attempts to set all this up I keep hitting walls, primarily because of my inexperience outside the Windows realm. For example, while setting up FreeNAS I somehow managed to screw up Folder/File Permissions and have been struggling for months to correct that situation. I got part of the way using Midnight Commander on the FreeNAS system but it was too time intensive to reset the Permissions manually as I could only figure out how to do that on a file/folder one by one basis. I’ve since discovered how to use the Zorin File Manager to access the FreeNAS Shares, but changes to Permissions seems to be inconsistent at folder and file level (some change, some don’t).
Ideally I’d like to run a Shell command on the FreeNAS Shares to reset folder/file Permissions, but (a) I don’t know the syntax and (b) I don’t know whether this is possible/safe. Maybe MC is a better tool for this but it doesn’t appear to allow top to bottom folder/file manipulations.
While I’m the first to recognise I’m well over my head here, once I get this sorted out and everything backed up, I can hopefully leave it all alone and get on with things.
I’m hoping you may be able to offer some help or guidance to a suitable resource and I thank you for your helpful input so far.
Cheers, Geoff

Well, that “hang” might as well be the success of the test, at least that was what I was able to dig up - telnet on Windows apparently shows blank page if the port is open. Which is just what we wanted to check. So it seems that there is a service listening there. Did you set something up according to the guide here, or this Zorin system runs out of the box?

It’s an ‘out of the box’ Zorin (plus some poking around by me in an attempt to configure). I did follow the guide to setting up RDP and it didn’t work first time (maybe I shouldn’t have followed the instruction to delete some stuff?).
I just tried it again without the ‘delete’- success!
I get the Windows desktop screen then a script saying: ‘sesman’ connection to ip 127.0.0.1, port 3350, then ‘login successful’, then ‘starting connection’ then ‘connection problem giving up some problem OK’.
Not sure which of the drop down options on the login in window for session - xorg, x11rdp, etc . .
Maybe that’s the blockage?

So you are now able to connect, and even login, only not able to start a remote session. That’s great progress. Can you find any error messages in the logfiles? You could check the .xsession-errors file in the user’s home directory, and also /var/log/xrdp.log or something similar.

And I’d say you could choose x11rdp from the options.

I could do that if I knew where to look.
Opening ‘Zorin Files’ shows a Home Directory but, according to the search bar at top of screen, no sign of anything resembling ‘.xsession-errors’ or ‘/var/log/xdrp.log’.
Thanks for the encouragement.

I would suggest using the command line. It may be alien at first, but enables much faster and clearer work in the long run.

If you open a terminal, you can type for example:

$ ls -al

Which will list all the files in the given (home) directory. You can narrow your search with grep:

$ ls -al | grep xession

Which will show only the file(s) that match the pattern.

You may not have permission to read the xrdp.log, so you need to use sudo to access it. For example, if you would like to print the whole file, you could execute the following:

$ sudo cat /var/log/xrdp.log

Thanks, this worked with the latest official Windows 10 Pro, 20H2, to use xrdp from it after installing xrdp to Ubuntu 20.04, fixing the black screen I got ever time/every way. Don’t forget that Window’s also has to have firewall changes (from Control Panel) to allow port 3389 through for it’s own Remote Desktop (at least on Pro.) I had to restart my Ubuntu VirtualBox for it to take effect. Onto trying it on another non-VirtualBox setup to get into my wife’s system that is running on a NUC. Thanks Paolo!

I have to create an account to comment. Yeah the tutorial works great and like others I got Black screen. It just because we got an account that logged in. We just need to log out.
With GUI: gnome-session-quit
Without GUI: exit
Or we just need to reboot the server if we don’t know how.

Hi, I followed your Tutorial but when I tried to log in, I didn‘t get access to the desktop but something different appeared.
image
When I logged in there again this window appeared
(I can‘t put the picture in here so I‘ll send it as an answer)
What have I done wrong?

Here is the second picture
image