Unable to connect my ts3322 to chromebook

I am writing this post to seek assistance with a connecting my ts3322 to chromebook [https://www.lenovo.com/fr/fr/chromebook/]. I have tried the following steps to troubleshoot the problem:

Check your printer’s compatibility: Make sure your printer is compatible with Chrome OS. You can check this by visiting the Chromebook’s support page or checking the printer’s manual.

Connect via USB: Try connecting your printer to your Chromebook via USB. Make sure your printer is turned on and that the USB cable is securely connected to both the printer and the Chromebook.

Connect via Wi-Fi: If your printer supports Wi-Fi, try connecting it to your Wi-Fi network. Make sure your printer is turned on and that it’s connected to your Wi-Fi network. Then, on your Chromebook, click on the status area (bottom right corner of the screen) and select the Wi-Fi network your printer is connected to.

Install the printer driver: If your printer is compatible with Chrome OS but still isn’t working, you may need to install the printer driver. Go to the Chrome Web Store and search for your printer’s manufacturer to find the appropriate driver.

Check for updates: Make sure your Chromebook and printer are both up to date with the latest software updates. This can sometimes fix connectivity issues.

But the problem is still here.
If anyone has faced similar challenges or has experience in connection. I would appreciate your insights and advice.
Thank you for your time.

I don’t own this printer and don’t use Chromebook, but I saw at Canon’s tech specs page that this printer is wireless-capable (it supports wireless networks compliant with the standards IEEE 802.11b, 802.11g and 802.11n operating at the electromagnetic frequency of 2.4 GHz), so I have to ask: have you tried adding this printer manually?

  1. Make sure that both your printer and your Chromebook are connected to the same Wi-Fi network with the same name (SSID) and the same frequency of 2.4 GHz. If any of them is connected to a 5.0 GHz network, they are going to be invisible to each other.

  2. Once they’re both connected to the same network and using the same signal frequency, find out the IPv4 address for your wireless printer (if you’re unable to find it, install the Android app on your Android phone or the iOS app on your iPhone, make sure that your phone is connected to the same wireless network at 2.4 GHz and then use such app to find the printer’s IPv4 address. Examples of IPv4 addresses:, etc.), then access the Chromebook’s settings, control panel or whatever and find the Manage Printers option or the equivalent option available.

  3. Based on your report, such printer manager won’t detect the printer, then click on Add Printer or whatever corresponding button is available, then, for the IP address, type the printer’s actual IPv4 address, and if there’s an option to select the network’s communication protocol, select IPPS instead of IPP, then click on the Add button and see if the printer is indeed added to the operating system (ChromeOS).

I don’t know if this is going to work, but it’s worth trying. Good luck. :four_leaf_clover:

If the tip above doesn’t work, I recommend trying to use CUPS (Common UNIX Printing System).

Chromebooks use ChromeOS, which is an operating system based on Linux, which in turn is a UNIX (i.e. POSIX-compliant) operating system, therefore it must (or should, theoretically) support CUPS and printing through CUPS.

There’s a Chrome browser extension that helps you access CUPS service if it’s available.

The default CUPS port it 631, so you may want to try to access http://localhost:631 in your web browser to see if a CUPS web interface is loaded. If it is, then authenticate with the same username and password that you use to log into ChromeOS.

According with Driverless Printers - OpenPrinting (search for 3322), your printer supports the AirPrinter technology, which means that if you own an iPhone or iPad, you can print from it straight to the printer without having to install any driver. Using your movie device may be a workaround if you can’t manage to use CUPS, either.