Urgent -18.04 auto updated to 18.10 how to downgrade


#1

I’m at a loss. After running an apt-get update / upgrade, login message said to reboot. I rebooted and my VMs will not boot with error:

root@srv01kvm01:/var/lib/libvirt/images# virsh start bs01
error: Failed to start domain bs01
error: internal error: qemu unexpectedly closed the monitor: 2018-08-28T21:19:24.892135Z qemu-system-x86_64: warning: host doesn't support requested feature: CPUID.80000001H:ECX.svm [bit 2]
Could not read keymap file: 'en-us'

Looked to the top and I saw Cosmic Cuttlefish 18.10 :exploding_head:

“var/log/apt/history”

Start-Date: 2018-08-28  05:02:30
Commandline: apt-get upgrade
Requested-By: mpadmin (1000)
Upgrade: debconf:amd64 (1.5.66, 1.5.69), libgssapi3-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), libjson-glib-1.0-0:amd64 (1.4.2-3, 1.4.2-4), manpages:amd64 (4.15-1, 4.16-1), perl-base:amd64 (5.26.1-6ubuntu0.1, 5.26.2-7), libnginx-mod-http-geoip:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), libpolkit-gobject-1-0:amd64 (0.105-20, 0.105-21), seabios:amd64 (1.10.2-1ubuntu1, 1.11.1-1), libguestfs-hfsplus:amd64 (1:1.36.13-1ubuntu3, 1:1.36.13-1ubuntu3.1), libusb-1.0-0:amd64 (2:1.0.21-2, 2:1.0.22-2), libhttp-message-perl:amd64 (6.14-1, 6.18-1), libnl-route-3-200:amd64 (3.2.29-0ubuntu3, 3.4.0-1), fuse:amd64 (2.9.7-1ubuntu1, 2.9.8-1ubuntu1), libkrb5-3:amd64 (1.16-2build1, 1.16-2ubuntu1), dosfstools:amd64 (4.1-1, 4.1-2), libgssapi-krb5-2:amd64 (1.16-2build1, 1.16-2ubuntu1), python-psutil:amd64 (5.4.2-1, 5.4.6-1build1), libpangoft2-1.0-0:amd64 (1.40.14-1, 1.42.4-1), libwww-robotrules-perl:amd64 (6.01-1, 6.02-1), libnghttp2-14:amd64 (1.30.0-1ubuntu1, 1.32.0-1), liblapack3:amd64 (3.7.1-4ubuntu1, 3.8.0-1), libseccomp2:amd64 (2.3.1-2.1ubuntu4, 2.3.3-3ubuntu1), glib-networking-services:amd64 (2.56.0-1, 2.57.90-1ubuntu1), landscape-common:amd64 (18.01-0ubuntu3.1, 18.01-0ubuntu4), fonts-font-awesome:amd64 (4.7.0~dfsg-3, 5.0.10+really4.7.0~dfsg-1), libaudit-common:amd64 (1:2.8.2-1ubuntu1, 1:2.8.3-1ubuntu2), libcom-err2:amd64 (1.44.1-1, 1.44.4-2), libcups2:amd64 (2.2.7-1ubuntu2, 2.2.8-5ubuntu1), intel-microcode:amd64 (3.20180425.1~ubuntu0.18.04.1, 3.20180807a.1), pollinate:amd64 (4.33-0ubuntu1~18.04.1, 4.33-0ubuntu1), libwind0-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), update-manager-core:amd64 (1:18.04.11, 1:18.10.3), networkd-dispatcher:amd64 (1.7-0ubuntu3, 1.7-0ubuntu6), libsemanage1:amd64 (2.7-2build2, 2.8-1build1), uuid-runtime:amd64 (2.31.1-0.4ubuntu3.1, 2.32-0.1ubuntu1), python3-zope.interface:amd64 (4.3.2-1build2, 4.3.2-1build3), python-openssl:amd64 (17.5.0-1ubuntu1, 18.0.0-1), libfdisk1:amd64 (2.31.1-0.4ubuntu3.1, 2.32-0.1ubuntu1), publicsuffix:amd64 (20180223.1310-1, 20180523.2326-2), gnupg-utils:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), ed:amd64 (1.10-2.1, 1.14.2-2), libnet-ssleay-perl:amd64 (1.84-1build1, 1.85-1), ifupdown:amd64 (0.8.17ubuntu1.1, 0.8.34ubuntu1), libcurl4:amd64 (7.58.0-2ubuntu3.1, 7.60.0-2ubuntu1), libxml2-utils:amd64 (2.9.4+dfsg1-6.1ubuntu1, 2.9.4+dfsg1-7build1), libapt-inst2.0:amd64 (1.6.1, 1.7.0~alpha3), gpg-wks-client:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), libldap-2.4-2:amd64 (2.4.45+dfsg-1ubuntu1, 2.4.46+dfsg-5ubuntu1), python3-software-properties:amd64 (0.96.24.32.3, 0.96.27), openssl:amd64 (1.1.0g-2ubuntu4, 1.1.0g-2ubuntu5), cloud-initramfs-dyn-netconf:amd64 (0.40ubuntu1, 0.42ubuntu1), sntp:amd64 (1:4.2.8p10+dfsg-5ubuntu7, 1:4.2.8p10+dfsg-5ubuntu7.1), libgirepository-1.0-1:amd64 (1.56.1-1, 1.57.2-2), byobu:amd64 (5.125-0ubuntu1, 5.127-0ubuntu1), qemu-system-mips:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.11+dfsg-1ubuntu7.4), gnupg-l10n:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), libibverbs1:amd64 (17.1-1, 19.0-1), libgdk-pixbuf2.0-0:amd64 (2.36.11-2, 2.36.12-2), qemu-system-misc:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.11+dfsg-1ubuntu7.4), python-oslo.i18n:amd64 (3.19.0-0ubuntu1, 3.21.0-0ubuntu1), liblcms2-2:amd64 (2.9-1, 2.9-2), libcairo-gobject2:amd64 (1.15.10-2, 1.15.12-1), update-notifier-common:amd64 (3.192.1, 3.192.7), python-yaml:amd64 (3.12-1build2, 3.12-1build3), libnl-genl-3-200:amd64 (3.2.29-0ubuntu3, 3.4.0-1), git-man:amd64 (1:2.17.1-1ubuntu0.1, 1:2.17.1-1ubuntu1), libsystemd0:amd64 (237-3ubuntu10, 237-3ubuntu10.3), glib-networking:amd64 (2.56.0-1, 2.57.90-1ubuntu1), base-passwd:amd64 (3.5.44, 3.5.45), libhttp-negotiate-perl:amd64 (6.00-2, 6.01-1), grub-common:amd64 (2.02-2ubuntu8, 2.02+dfsg1-5ubuntu1), apt:amd64 (1.6.1, 1.7.0~alpha3), libgd3:amd64 (2.2.5-4, 2.2.5-4ubuntu0.2), libdate-manip-perl:amd64 (6.60-1, 6.72-1), libheimntlm0-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), python-simplejson:amd64 (3.13.2-1, 3.15.0-1build1), gstreamer1.0-plugins-good:amd64 (1.14.0-1ubuntu1, 1.14.2-1ubuntu3), libgs9:amd64 (9.22~dfsg+1-0ubuntu1.1, 9.23~dfsg+1-0ubuntu2), python3-systemd:amd64 (234-1build1, 234-2build1), libkmod2:amd64 (24-1ubuntu3, 25-1ubuntu1), libpsl5:amd64 (0.19.1-5build1, 0.20.2-1), debconf-i18n:amd64 (1.5.66, 1.5.69), libasound2-data:amd64 (1.1.3-5ubuntu0.1, 1.1.6-1ubuntu1), bridge-utils:amd64 (1.5-15ubuntu1, 1.5-16ubuntu1), libmount1:amd64 (2.31.1-0.4ubuntu3.1, 2.32-0.1ubuntu1), gcc-8-base:amd64 (8-20180414-1ubuntu2, 8.2.0-4ubuntu1), snapd:amd64 (2.32.9+18.04, 2.35+18.10), python-libvirt:amd64 (4.0.0-1, 4.6.0-1), libsqlite3-0:amd64 (3.22.0-1, 3.24.0-1), liborc-0.4-0:amd64 (1:0.4.28-1, 1:0.4.28-2), python-tz:amd64 (2018.3-2, 2018.5-1), nginx-core:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), libicu60:amd64 (60.2-3ubuntu3, 60.2-6ubuntu1), libelf1:amd64 (0.170-0.4, 0.170-0.5), binutils:amd64 (2.30-20ubuntu2~18.04, 2.31.1-3ubuntu2), squashfs-tools:amd64 (1:4.3-6, 1:4.3-6ubuntu1), libgpg-error0:amd64 (1.27-6, 1.32-1), libbsd0:amd64 (0.8.7-1, 0.9.1-1), language-selector-common:amd64 (0.188.1, 0.190), e2fsprogs:amd64 (1.44.1-1, 1.44.4-2), lshw:amd64 (02.18-0.1ubuntu6, 02.18-0.1ubuntu7), libavahi-common-data:amd64 (0.7-3.1ubuntu1, 0.7-4ubuntu2), librbd1:amd64 (12.2.4-0ubuntu1.1, 12.2.4-0ubuntu1.1build1), fonts-ubuntu-console:amd64 (0.83-2, 0.83-4), libgmp10:amd64 (2:6.1.2+dfsg-2, 2:6.1.2+dfsg-3), ibverbs-providers:amd64 (17.1-1, 19.0-1), perl-modules-5.26:amd64 (5.26.1-6ubuntu0.1, 5.26.2-7), libavahi-common3:amd64 (0.7-3.1ubuntu1, 0.7-4ubuntu2), sudo:amd64 (1.8.21p2-3ubuntu1, 1.8.23-2ubuntu1), libguestfs0:amd64 (1:1.36.13-1ubuntu3, 1:1.36.13-1ubuntu3.1), python3-pam:amd64 (0.4.2-13.2ubuntu4, 0.4.2-13.2ubuntu5), ubuntu-standard:amd64 (1.417, 1.423), libmp3lame0:amd64 (3.100-2, 3.100-2build1), libheimbase1-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), console-setup-linux:amd64 (1.178ubuntu2, 1.178ubuntu9), gpg-wks-server:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), libnuma1:amd64 (2.0.11-2.1, 2.0.11-2.2), gcc-7-base:amd64 (7.3.0-16ubuntu3, 7.3.0-28ubuntu1), python-apt-common:amd64 (1.6.0, 1.7.0~alpha2ubuntu2+really1.6.2ubuntu1), open-vm-tools:amd64 (2:10.2.0-3ubuntu3, 2:10.3.0-0ubuntu1), git:amd64 (1:2.17.1-1ubuntu0.1, 1:2.17.1-1ubuntu1), openssh-sftp-server:amd64 (1:7.6p1-4, 1:7.7p1-4), libthai-data:amd64 (0.1.27-2, 0.1.28-1), gpg:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), libbrlapi0.6:amd64 (5.5-4ubuntu2, 5.6-4ubuntu3), libaio1:amd64 (0.3.110-5, 0.3.111-1), libsepol1:amd64 (2.7-1, 2.8-1), libpolkit-agent-1-0:amd64 (0.105-20, 0.105-21), libk5crypto3:amd64 (1.16-2build1, 1.16-2ubuntu1), grub2-common:amd64 (2.02-2ubuntu8, 2.02+dfsg1-5ubuntu1), iputils-tracepath:amd64 (3:20161105-1ubuntu2, 3:20180629-1ubuntu1), ebtables:amd64 (2.0.10.4-3.5ubuntu2.18.04.1, 2.0.10.4-3.5ubuntu5), zerofree:amd64 (1.0.4-1, 1.1.1-1), udev:amd64 (237-3ubuntu10, 237-3ubuntu10.3), console-setup:amd64 (1.178ubuntu2, 1.178ubuntu9), gstreamer1.0-plugins-base:amd64 (1.14.0-2ubuntu1, 1.14.2-1ubuntu1), libxcb-shm0:amd64 (1.13-1, 1.13-3), popularity-contest:amd64 (1.66ubuntu1, 1.67ubuntu1), libvirt-clients:amd64 (4.0.0-1ubuntu8.2, 4.6.0-2ubuntu2), python-stevedore:amd64 (1:1.28.0-0ubuntu1, 1:1.29.0-0ubuntu1), ubuntu-server:amd64 (1.417, 1.423), readline-common:amd64 (7.0-3, 7.0-5), libxcb-render0:amd64 (1.13-1, 1.13-3), language-pack-en:amd64 (1:18.04+20180423, 1:18.10+20180731), librdmacm1:amd64 (17.1-1, 19.0-1), libquadmath0:amd64 (8-20180414-1ubuntu2, 8.2.0-4ubuntu1), qemu-user:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.11+dfsg-1ubuntu7.4), libwww-perl:amd64 (6.31-1, 6.35-2), isc-dhcp-common:amd64 (4.3.5-3ubuntu7, 4.3.5-3ubuntu9), amd64-microcode:amd64 (3.20171205.1, 3.20180524.1ubuntu1), libmagic1:amd64 (1:5.32-2ubuntu0.1, 1:5.34-2), command-not-found-data:amd64 (18.04.5, 18.10.0~pre1), libspice-server1:amd64 (0.14.0-1ubuntu2.1, 0.14.0-1ubuntu3), libapt-pkg5.0:amd64 (1.6.1, 1.7.0~alpha3), libwavpack1:amd64 (5.1.0-2ubuntu1.1, 5.1.0-4), libvirt-daemon-driver-storage-rbd:amd64 (4.0.0-1ubuntu8.2, 4.6.0-2ubuntu2), libmpdec2:amd64 (2.4.2-1ubuntu1, 2.4.2-2), initramfs-tools-bin:amd64 (0.130ubuntu10, 0.131ubuntu9), grub-pc:amd64 (2.02-2ubuntu8, 2.02+dfsg1-5ubuntu1), python-lxml:amd64 (4.2.1-1, 4.2.1-1build1), fontconfig-config:amd64 (2.12.6-0ubuntu2, 2.13.0-5ubuntu3), libnet-http-perl:amd64 (6.17-1, 6.18-1), libopus0:amd64 (1.1.2-1ubuntu1, 1.3~beta+20180518-1), debianutils:amd64 (4.8.4, 4.8.6), libexpat1:amd64 (2.2.5-3, 2.2.6-1), glib-networking-common:amd64 (2.56.0-1, 2.57.90-1ubuntu1), nginx-common:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), libgstreamer-plugins-good1.0-0:amd64 (1.14.0-1ubuntu1, 1.14.2-1ubuntu3), kmod:amd64 (24-1ubuntu3, 25-1ubuntu1), libudev1:amd64 (237-3ubuntu10, 237-3ubuntu10.3), rsyslog:amd64 (8.32.0-1ubuntu4, 8.32.0-1ubuntu5), net-tools:amd64 (1.60+git20161116.90da8a0-1ubuntu1, 1.60+git20161116.90da8a0-2ubuntu1), libapparmor1:amd64 (2.12-4ubuntu5, 2.12-4ubuntu7), libsoup2.4-1:amd64 (2.62.1-1, 2.63.90-1), libguestfs-perl:amd64 (1:1.36.13-1ubuntu3, 1:1.36.13-1ubuntu3.1), libio-socket-ssl-perl:amd64 (2.056-1, 2.059-1), adduser:amd64 (3.116ubuntu1, 3.117ubuntu1), krb5-locales:amd64 (1.16-2build1, 1.16-2ubuntu1), libguestfs-tools:amd64 (1:1.36.13-1ubuntu3, 1:1.36.13-1ubuntu3.1), libgcc1:amd64 (1:8-20180414-1ubuntu2, 1:8.2.0-4ubuntu1), dirmngr:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), libss2:amd64 (1.44.1-1, 1.44.4-2), mount:amd64 (2.31.1-0.4ubuntu3.1, 2.32-0.1ubuntu1), liblxc1:amd64 (3.0.0-0ubuntu2, 3.0.1-0ubuntu2), libperl5.26:amd64 (5.26.1-6ubuntu0.1, 5.26.2-7), ntp:amd64 (1:4.2.8p10+dfsg-5ubuntu7, 1:4.2.8p10+dfsg-5ubuntu7.1), libsemanage-common:amd64 (2.7-2build2, 2.8-1build1), python-cryptography:amd64 (2.1.4-1ubuntu1.1, 2.3-1), binutils-x86-64-linux-gnu:amd64 (2.30-20ubuntu2~18.04, 2.31.1-3ubuntu2), grub-pc-bin:amd64 (2.02-2ubuntu8, 2.02+dfsg1-5ubuntu1), ntpdate:amd64 (1:4.2.8p10+dfsg-5ubuntu7, 1:4.2.8p10+dfsg-5ubuntu7.1), libext2fs2:amd64 (1.44.1-1, 1.44.4-2), libguestfs-reiserfs:amd64 (1:1.36.13-1ubuntu3, 1:1.36.13-1ubuntu3.1), ubuntu-minimal:amd64 (1.417, 1.423), apport:amd64 (2.20.9-0ubuntu7.2, 2.20.10-0ubuntu9), libvirt-bin:amd64 (4.0.0-1ubuntu8.2, 4.0.0-1ubuntu13), libblkid1:amd64 (2.31.1-0.4ubuntu3.1, 2.32-0.1ubuntu1), dpkg:amd64 (1.19.0.5ubuntu2, 1.19.0.5ubuntu3), fontconfig:amd64 (2.12.6-0ubuntu2, 2.13.0-5ubuntu3), libtiff5:amd64 (4.0.9-5, 4.0.9-6), qemu:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.11+dfsg-1ubuntu7.4), python-cffi-backend:amd64 (1.11.5-1, 1.11.5-1build1), librtmp1:amd64 (2.4+20151223.gitfa8646d.1-1, 2.4+20151223.gitfa8646d.1-2), libisc-export169:amd64 (1:9.11.3+dfsg-1ubuntu1.1, 1:9.11.4+dfsg-3ubuntu1), python3-cryptography:amd64 (2.1.4-1ubuntu1.1, 2.3-1), busybox-static:amd64 (1:1.27.2-2ubuntu3, 1:1.27.2-2ubuntu4), python3-distupgrade:amd64 (1:18.04.19, 1:18.10.8), python-debtcollector:amd64 (1.13.0-0ubuntu1, 1.19.0-1), man-db:amd64 (2.8.3-2, 2.8.4-2), libmagic-mgc:amd64 (1:5.32-2ubuntu0.1, 1:5.34-2), libpangocairo-1.0-0:amd64 (1.40.14-1, 1.42.4-1), libpulse0:amd64 (1:11.1-1ubuntu7.1, 1:12.2-0ubuntu2), python3-debconf:amd64 (1.5.66, 1.5.69), python3-commandnotfound:amd64 (18.04.5, 18.10.0~pre1), libmpg123-0:amd64 (1.25.10-1, 1.25.10-2), gir1.2-glib-2.0:amd64 (1.56.1-1, 1.57.2-2), libxenstore3.0:amd64 (4.9.2-0ubuntu1, 4.9.2-0ubuntu2), xfsprogs:amd64 (4.9.0+nmu1ubuntu2, 4.15.1-1ubuntu1), python3-update-manager:amd64 (1:18.04.11, 1:18.10.3), libxcb1:amd64 (1.13-1, 1.13-3), ubuntu-release-upgrader-core:amd64 (1:18.04.19, 1:18.10.8), python3-apport:amd64 (2.20.9-0ubuntu7.2, 2.20.10-0ubuntu9), libkrb5support0:amd64 (1.16-2build1, 1.16-2ubuntu1), libxmlsec1-openssl:amd64 (1.2.25-1build1, 1.2.26-3), libjbig2dec0:amd64 (0.13-6, 0.14-1), libpcre3:amd64 (2:8.39-9, 2:8.39-11), sed:amd64 (4.4-2, 4.5-1), whiptail:amd64 (0.52.20-1ubuntu1, 0.52.20-4ubuntu3), libvorbisenc2:amd64 (1.3.5-4.2, 1.3.6-1), libnewt0.52:amd64 (0.52.20-1ubuntu1, 0.52.20-4ubuntu3), python3-cffi-backend:amd64 (1.11.5-1, 1.11.5-1build1), libfuse2:amd64 (2.9.7-1ubuntu1, 2.9.8-1ubuntu1), libgfortran4:amd64 (7.3.0-16ubuntu3, 7.3.0-28ubuntu1), libcupsfilters1:amd64 (1.20.2-0ubuntu3, 1.20.4-1), qemu-utils:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.12+dfsg-3ubuntu4), dmidecode:amd64 (3.1-1, 3.1-2), python3-click:amd64 (6.7-3, 6.7-5), libmspack0:amd64 (0.6-3, 0.7-1), libvirt-daemon-system:amd64 (4.0.0-1ubuntu8.2, 4.6.0-2ubuntu2), python-pygments:amd64 (2.2.0+dfsg-1, 2.2.0+dfsg-1ubuntu1), libnginx-mod-http-image-filter:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), tar:amd64 (1.29b-2, 1.30+dfsg-2), systemd-sysv:amd64 (237-3ubuntu10, 237-3ubuntu10.3), libuuid1:amd64 (2.31.1-0.4ubuntu3.1, 2.32-0.1ubuntu1), libnl-3-200:amd64 (3.2.29-0ubuntu3, 3.4.0-1), libldap-common:amd64 (2.4.45+dfsg-1ubuntu1, 2.4.46+dfsg-5ubuntu1), libgcrypt20:amd64 (1.8.1-4ubuntu1, 1.8.3-1ubuntu1), libhcrypto4-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), ufw:amd64 (0.35-5, 0.35-6), python-pkg-resources:amd64 (39.0.1-2, 39.2.0-1), libkeyutils1:amd64 (1.5.9-9.2ubuntu2, 1.5.9-9.3), python-html5lib:amd64 (0.999999999-1, 1.0.1-1), libnetfilter-conntrack3:amd64 (1.0.6-2, 1.0.7-1), libselinux1:amd64 (2.7-2build2, 2.8-1build1), liblz4-1:amd64 (0.0~r131-2ubuntu3, 1.8.2-1ubuntu1), gpgv:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), python-apt:amd64 (1.6.0, 1.7.0~alpha2ubuntu2+really1.6.2ubuntu1), ieee-data:amd64 (20180204.1, 20180805.1), libjson-glib-1.0-common:amd64 (1.4.2-3, 1.4.2-4), libpam-systemd:amd64 (237-3ubuntu10, 237-3ubuntu10.3), libgstreamer-plugins-base1.0-0:amd64 (1.14.0-2ubuntu1, 1.14.2-1ubuntu1), syslinux:amd64 (3:6.03+dfsg1-2, 3:6.04~git20171011.af7e95c3+dfsg1-4), qemu-system-sparc:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.11+dfsg-1ubuntu7.4), distro-info-data:amd64 (0.37ubuntu0.1, 0.38), libdrm2:amd64 (2.4.91-2, 2.4.93-1), ncurses-term:amd64 (6.1-1ubuntu1.18.04, 6.1+20180210-4ubuntu1), python-webob:amd64 (1:1.7.3-2fakesync1, 1:1.8.2-0ubuntu1), python3-yaml:amd64 (3.12-1build2, 3.12-1build3), gstreamer1.0-x:amd64 (1.14.0-2ubuntu1, 1.14.2-1ubuntu1), python3-pkg-resources:amd64 (39.0.1-2, 39.2.0-1), python-bs4:amd64 (4.6.0-1, 4.6.3-1), ghostscript:amd64 (9.22~dfsg+1-0ubuntu1.1, 9.23~dfsg+1-0ubuntu2), python3-openssl:amd64 (17.5.0-1ubuntu1, 18.0.0-1), systemd:amd64 (237-3ubuntu10, 237-3ubuntu10.3), libgomp1:amd64 (8-20180414-1ubuntu2, 8.2.0-4ubuntu1), libsmartcols1:amd64 (2.31.1-0.4ubuntu3.1, 2.32-0.1ubuntu1), libgdk-pixbuf2.0-bin:amd64 (2.36.11-2, 2.36.12-2), libnginx-mod-mail:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), xxd:amd64 (2:8.0.1453-1ubuntu1, 2:8.0.1766-1ubuntu1), libthai0:amd64 (0.1.27-2, 0.1.28-1), libpolkit-backend-1-0:amd64 (0.105-20, 0.105-21), libfontconfig1:amd64 (2.12.6-0ubuntu2, 2.13.0-5ubuntu3), openssh-server:amd64 (1:7.6p1-4, 1:7.7p1-4), apt-utils:amd64 (1.6.1, 1.7.0~alpha3), libgdk-pixbuf2.0-common:amd64 (2.36.11-2, 2.36.12-2), bcache-tools:amd64 (1.0.8-2build1, 1.0.8-3), qemu-user-binfmt:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.11+dfsg-1ubuntu7.4), libxen-4.9:amd64 (4.9.2-0ubuntu1, 4.9.2-0ubuntu2), openssh-client:amd64 (1:7.6p1-4, 1:7.7p1-4), iputils-ping:amd64 (3:20161105-1ubuntu2, 3:20180629-1ubuntu1), sosreport:amd64 (3.5-1ubuntu3.18.04.1, 3.5-1ubuntu4), libnss-systemd:amd64 (237-3ubuntu10, 237-3ubuntu10.3), libgs9-common:amd64 (9.22~dfsg+1-0ubuntu1.1, 9.23~dfsg+1-0ubuntu2), keyboard-configuration:amd64 (1.178ubuntu2, 1.178ubuntu9), bsdutils:amd64 (1:2.31.1-0.4ubuntu3.1, 1:2.32-0.1ubuntu1), binutils-common:amd64 (2.30-20ubuntu2~18.04, 2.31.1-3ubuntu2), python3-dbus:amd64 (1.2.6-1, 1.2.8-2build1), libasound2:amd64 (1.1.3-5ubuntu0.1, 1.1.6-1ubuntu1), libvirt0:amd64 (4.0.0-1ubuntu8.2, 4.6.0-2ubuntu2), libjpeg-turbo8:amd64 (1.5.2-0ubuntu5, 1.5.2-0ubuntu6), libglib2.0-data:amd64 (2.56.1-2ubuntu1, 2.57.2-1), language-pack-en-base:amd64 (1:18.04+20180423, 1:18.10+20180731), ncurses-base:amd64 (6.1-1ubuntu1.18.04, 6.1+20180210-4ubuntu1), policykit-1:amd64 (0.105-20, 0.105-21), findutils:amd64 (4.6.0+git+20170828-2, 4.6.0+git+20180808-2), libcap-ng0:amd64 (0.7.7-3.1, 0.7.9-1), libxml2:amd64 (2.9.4+dfsg1-6.1ubuntu1, 2.9.4+dfsg1-7build1), file:amd64 (1:5.32-2ubuntu0.1, 1:5.34-2), libfdt1:amd64 (1.4.5-3, 1.4.7-1), python3-gi:amd64 (3.26.1-2, 3.28.2-1build1), pciutils:amd64 (1:3.5.2-1ubuntu1, 1:3.5.2-1ubuntu2), libflac8:amd64 (1.3.2-1, 1.3.2-3), ethtool:amd64 (1:4.15-0ubuntu1, 1:4.16-1), libidn11:amd64 (1.33-2.1ubuntu1, 1.33-2.2ubuntu1), libbinutils:amd64 (2.30-20ubuntu2~18.04, 2.31.1-3ubuntu2), libgnutls30:amd64 (3.5.18-1ubuntu1, 3.5.19-1ubuntu1), unattended-upgrades:amd64 (1.1ubuntu1, 1.4ubuntu2), libnss3:amd64 (2:3.35-2ubuntu2, 2:3.36.1-1ubuntu1), libroken18-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), libtwolame0:amd64 (0.3.13-3, 0.3.13-4), libnginx-mod-stream:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), perl:amd64 (5.26.1-6ubuntu0.1, 5.26.2-7), rsync:amd64 (3.1.2-2.1ubuntu1, 3.1.2-2.2), apparmor:amd64 (2.12-4ubuntu5, 2.12-4ubuntu7), libunistring2:amd64 (0.9.9-0ubuntu1, 0.9.10-1ubuntu1), command-not-found:amd64 (18.04.5, 18.10.0~pre1), ssh-import-id:amd64 (5.7-0ubuntu1.1, 5.7-24-g4001a38e-0ubuntu1), libp11-kit0:amd64 (0.23.9-2, 0.23.13-2), libasn1-8-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), libkrb5-26-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), wget:amd64 (1.19.4-1ubuntu2.1, 1.19.5-1ubuntu1), mtools:amd64 (4.0.18-2ubuntu1, 4.0.18-2.1), linux-firmware:amd64 (1.173.1, 1.174), libvorbis0a:amd64 (1.3.5-4.2, 1.3.6-1), libssl1.1:amd64 (1.1.0g-2ubuntu4, 1.1.0g-2ubuntu5), libnginx-mod-http-xslt-filter:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), overlayroot:amd64 (0.40ubuntu1, 0.42ubuntu1), libharfbuzz0b:amd64 (1.7.2-1ubuntu1, 1.8.8-2), libtasn1-6:amd64 (4.13-2, 4.13-3), gnupg:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), cloud-initramfs-copymods:amd64 (0.40ubuntu1, 0.42ubuntu1), libpci3:amd64 (1:3.5.2-1ubuntu1, 1:3.5.2-1ubuntu2), libblas3:amd64 (3.7.1-4ubuntu1, 3.8.0-1), libyaml-0-2:amd64 (0.1.7-2ubuntu3, 0.2.1-1), netcat-openbsd:amd64 (1.187-1ubuntu0.1, 1.190-2), libbluetooth3:amd64 (5.48-0ubuntu3, 5.50-0ubuntu1), keyutils:amd64 (1.5.9-9.2ubuntu2, 1.5.9-9.3), python-wrapt:amd64 (1.9.0-3, 1.9.0-3build1), gettext-base:amd64 (0.19.8.1-6, 0.19.8.1-7), libcairo2:amd64 (1.15.10-2, 1.15.12-1), libcupsimage2:amd64 (2.2.7-1ubuntu2, 2.2.8-5ubuntu1), syslinux-common:amd64 (3:6.03+dfsg1-2, 3:6.04~git20171011.af7e95c3+dfsg1-4), liblxc-common:amd64 (3.0.0-0ubuntu2, 3.0.1-0ubuntu2), libavc1394-0:amd64 (0.5.4-4build1, 0.5.4-5), libstdc++6:amd64 (8-20180414-1ubuntu2, 8.2.0-4ubuntu1), libnpth0:amd64 (1.5-3, 1.6-1), python3-gdbm:amd64 (3.6.5-3, 3.6.6-1), libavahi-client3:amd64 (0.7-3.1ubuntu1, 0.7-4ubuntu2), curl:amd64 (7.58.0-2ubuntu3.1, 7.60.0-2ubuntu1), libpango-1.0-0:amd64 (1.40.14-1, 1.42.4-1), libhx509-5-heimdal:amd64 (7.5.0+dfsg-1, 7.5.0+dfsg-2), libjs-sphinxdoc:amd64 (1.6.7-1ubuntu1, 1.7.5-6), poppler-data:amd64 (0.4.8-2, 0.4.9-2), qemu-block-extra:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.12+dfsg-3ubuntu4), python3-newt:amd64 (0.52.20-1ubuntu1, 0.52.20-4ubuntu3), python3-certifi:amd64 (2018.1.18-2, 2018.8.13-1), patch:amd64 (2.7.6-2ubuntu1, 2.7.6-3), gpg-agent:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), libgstreamer1.0-0:amd64 (1.14.0-1, 1.14.2-2), python3-problem-report:amd64 (2.20.9-0ubuntu7.2, 2.20.10-0ubuntu9), liburi-perl:amd64 (1.73-1, 1.74-1), libsamplerate0:amd64 (0.1.9-1, 0.1.9-2), python-numpy:amd64 (1:1.13.3-2ubuntu1, 1:1.14.5-1ubuntu3), libglib2.0-0:amd64 (2.56.1-2ubuntu1, 2.57.2-1), wireless-regdb:amd64 (2018.05.09-0ubuntu1~18.04.1, 2018.05.09-0ubuntu1), libidn2-0:amd64 (2.0.4-1.1build2, 2.0.4-2.2), install-info:amd64 (6.5.0.dfsg.1-2, 6.5.0.dfsg.1-4), python-pam:amd64 (0.4.2-13.2ubuntu4, 0.4.2-13.2ubuntu5), librados2:amd64 (12.2.4-0ubuntu1.1, 12.2.4-0ubuntu1.1build1), libxmlsec1:amd64 (1.2.25-1build1, 1.2.26-3), python-pil:amd64 (5.1.0-1, 5.2.0-2), qemu-system-common:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.12+dfsg-3ubuntu4), libaudit1:amd64 (1:2.8.2-1ubuntu1, 1:2.8.3-1ubuntu2), nfs-common:amd64 (1:1.3.4-2.1ubuntu5, 1:1.3.4-2.2ubuntu1), libcurl3-gnutls:amd64 (7.58.0-2ubuntu3.1, 7.60.0-2ubuntu1), initramfs-tools-core:amd64 (0.130ubuntu10, 0.131ubuntu9), gpgconf:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), python3-serial:amd64 (3.4-2, 3.4-4), python-ldap:amd64 (3.0.0-1, 3.1.0-2), initramfs-tools:amd64 (0.130ubuntu10, 0.131ubuntu9), python3-apt:amd64 (1.6.0, 1.7.0~alpha2ubuntu2+really1.6.2ubuntu1), libfribidi0:amd64 (0.19.7-2, 1.0.5-3), hdparm:amd64 (9.54+ds-1, 9.56+ds-2), qemu-system:amd64 (1:2.11+dfsg-1ubuntu7.3, 1:2.11+dfsg-1ubuntu7.4), libguestfs-xfs:amd64 (1:1.36.13-1ubuntu3, 1:1.36.13-1ubuntu3.1), libxslt1.1:amd64 (1.1.29-5, 1.1.32-2), libssl1.0.0:amd64 (1.0.2n-1ubuntu5, 1.0.2n-1ubuntu6), base-files:amd64 (10.1ubuntu2, 10.1ubuntu6), gpgsm:amd64 (2.2.4-1ubuntu1.1, 2.2.8-1ubuntu1), libdatrie1:amd64 (0.2.10-7, 0.2.12-1), libsigsegv2:amd64 (2.12-1, 2.12-2), tzdata:amd64 (2018d-1, 2018e-1), lxcfs:amd64 (3.0.0-0ubuntu1, 3.0.2-0ubuntu1), libvirt-daemon:amd64 (4.0.0-1ubuntu8.2, 4.6.0-2ubuntu2), python-guestfs:amd64 (1:1.36.13-1ubuntu3, 1:1.36.13-1ubuntu3.1), libdrm-common:amd64 (2.4.91-2, 2.4.93-1), nginx:amd64 (1.14.0-0ubuntu1, 1.15.2-0ubuntu2), liblzo2-2:amd64 (2.08-1.2, 2.10-0.1), busybox-initramfs:amd64 (1:1.27.2-2ubuntu3, 1:1.27.2-2ubuntu4), btrfs-progs:amd64 (4.15.1-1build1, 4.16.1-2ubuntu1), libslang2:amd64 (2.3.1a-3ubuntu1, 2.3.2-1ubuntu1), software-properties-common:amd64 (0.96.24.32.3, 0.96.27), liberror-perl:amd64 (0.17025-1, 0.17026-1), libpng16-16:amd64 (1.6.34-1, 1.6.34-2)
End-Date: 2018-08-28  05:17:54

Start-Date: 2018-08-28  05:22:47
Commandline: apt-get install rsnapshot
Requested-By: mpadmin (1000)
Install: liblchown-perl:amd64 (1.01-3build3, automatic), rsnapshot:amd64 (1.4.2-1)
End-Date: 2018-08-28  05:22:50

I looked at /etc/apt/sources.list and did note there was one reference to Cosmic:

#added for troublshooting initramfs-tools-core 10
deb ubuntu .cs. utah. edu/ ubuntu cosmic main
#deb-src

Could this really have forced an upgrade to 18.10?? Please help, deadline and no clue how to downgrade. I’ll take any wild geese


#2

Hi,

To confirm your running version could you post the contents of your /etc/os-release file?

About the issue: what settings do you have in /etc/libvirt/qemu.conf file regarding the following keys:
user=
group=


#3

For a generic downgrade guide you can visit our How to downgrade Ubuntu Linux system to its previous version