Wifi Adapter not detected


So I am trying to setup CentOS 8 and initially was trying to do this with no internet access. I have since learned it is a complete PITA to do this so bit the bullet and have plugged a USB Wifi Adapter in. Only to find it does not get recognised, it does on a windows system.

I first of all tried copying across the drivers from the CD but this didn’t do anything.

So I did the lsusb command and it does come up with a Realtek Semiconductor Corp entry. The ID is 0bda:c811 and from looking on the windows machine it is a Realtek RTL8811CU model. No other command seems to show anything though.

I have read lots of guides on installing a driver but they all seem to want me to download something, I have no internet though only that on another Windows PC. So is there somewhere I can get a driver to get this adapter working?

If it is of use the kernel version is = 4.18.0-240.el8.x86_64.

The only other option is to try and get an adapter that just works straight out of the box, so would this do the trick: TB® Ralink 5370 USB Wifi Dongle

Hi AFKMatrix,

Since you don’t have Internet connection on the CentOS machine itself, I’d suggest you download the driver from the vendor’s site to the other PC, and transfer it to the CentOS system by other means - local Ethernet connection, USB drive, etc.

I’ve found after what feels like hundreds of hours of frustration that most of the Linux variations don’t seem to like RealTek wifi adapters much, but they LOVE Ralink. I now have 2-3 RaLink wifi adapters in my parts box for use whenever Ubuntu is upgraded and I lose wifi, yet again.

Problem for me has been that RaLink will sometimes stop producing high gain wifi adapters for outdoor use so I have to drop back to RealTek as they seem to always have them. Kind of annoying that Ubuntu seems to kill the Realtek drivers every couple of upgrades. It seemed better lately but then…boom, driver stopped working about a month ago. That time though, it only took a search with my RaLink adapter to find the newer drivers that worked quickly. Usually it’s a several hour adventure.

So I’d suggest you use that RaLink dongle you have to do your searching for drivers for your Realtek, or just switch to it and abandon the Realtek if you can.