WiFi connects, ethernet doesn't


#1

Dell XPS 8700 Desktop i7-4790 16GB RAM dual boot Win 10 home / Ubuntu MATE 18.04.1

Win 10 installed on 1T HDD, UM on 120GB SATA SSD

When booted into Windows, both WiFi and ethernet connect

When booted into Ubuntu MATE, WiFi connects but ethernet will not.

I am not very experienced in linux CLI and seek guidance from those versed in linux and networking.

If someone is kind enough to assist this old guy, it will be much appreciated. Please let me know what information I might provide. The relevant commands will be very helpful.


#2

Hi Robert,

Welcome to our forums. To start with, can you please provide us with the output of for the following commands while the WiFi is disconnected:

Show current IP address:
$ ip a
List hardware:
$ lspci
Configuration files:
$ ls /etc/netplan/
$ cat /etc/netplan/01-network-manager-all.yaml
$ cat /etc/netplan/01-netcfg.yaml

Please visit this thread and confirm that your issue is not related.

Lubos


#3

MAC ADDRESSES/IP #'S HAVE BEEN NEUTERED (12:34:56:78:99:87 ). LET ME KNOW IF ANY ARE NEEDED

   $ ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
        link/ether 12:34:56:78:99:87 brd 12:34:56:78:99:87
    3: wlx00212f30a0d9: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
        link/ether 12:34:56:78:99:87 brd 12:34:56:78:99:87


$ lspci
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.7 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #8 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 745] (rev a2)
01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
04:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)



$ ls /etc/netplan/
01-network-manager-all.yaml



$ cat /etc/netplan/01-network-manager-all.yaml
 # Let NetworkManager manage all devices on this system
 network:
   version: 2
   renderer: NetworkManager




$ cat /etc/netplan/01-netcfg.yaml
cat: /etc/netplan/01-netcfg.yaml: No such file or directory

Hope I got that all right. If anything looks weird, say so and I will sort it.

Can’t say for sure yes or no regarding the link referred. Sounds like it might, but over my head.


#4

Thank you for the provided information.

So far all looks good. Please check Ethernet settings. Is the automatic connect enabled. Also check and post information from Ethernet tab.

Also try the following to see whether you get the IP address. Make sure that the eth cable is connect:

$ ip a
$ sudo systemctl stop network-manager
$ sudo dhclient enp0s3
$ ip a

Lubos


#5

Editing Wired Connection 1:

Ethernet Tab:

-Device: (contains correct MAC address of Realtek adapter)
-Cloned MAC address: (is blank)
-MTU: automatic
-Wake on LAN: Default is checked
-Wake on LAN password: (is blank)
-Link Negotiation: Ignore is selected
-Speed: 100Mb/s (but is greyed out)
-Duplex: Full (but is greyed out)


The following with WiFi disabled, but computer not restarted. (MAC addresses neutered)

“ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether 12:34:56:78:99:87 brd ff:ff:ff:ff:ff:ff
3: wlx00212f30a0d9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 12:34:56:78:99:87 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.236/24 brd 192.168.1.255 scope global dynamic noprefixroute wlx00212f30a0d9
valid_lft 85189sec preferred_lft 85189sec
inet6 12:34:56:78:99:87/64 scope global temporary dynamic
valid_lft 3594sec preferred_lft 3594sec
inet6 12:34:56:78:99:87/64 scope global dynamic mngtmpaddr noprefixroute
valid_lft 3594sec preferred_lft 3594sec
inet6 12:34:56:78:99:87/64 scope link noprefixroute
valid_lft forever preferred_lft forever”

“sudo systemctl stop network-manager
(nothing returned)”

"sudo dhclient enp0s3
Cannot find device “enp0s3”

“p a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether 12:34:56:78:99:87 brd ff:ff:ff:ff:ff:ff
3: wlx00212f30a0d9: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether 12:34:56:78:99:87 brd ff:ff:ff:ff:ff:ff”


#6

Please try again with the enp3s0 device name as returned from previous command. What we are looking for here is that after you execute the last ip a command your network interface enp3s0 should have receive a new IP address from dhcp. Please try:

$ ip a
$ sudo systemctl stop network-manager
$ sudo dhclient enp3s0
$ ip a

#7

2 posts were split to a new topic: Repair MS windows and Ubuntu dual boot


#8

I had this issue 2 days ago and resolved it by doing the following via the GUI.
Right click on your network icon and select ‘Edit connections’.
Under Ethernet highlight ‘Ethernet connection1’ then click on the ‘Delete’ button. Confirm by clicking on ‘Delete’ button.
Click on the ‘Add’ button and ensure ‘Ethernet’ is selected. Click on the ‘Create’ button. Click on ‘Save’.
You may need to restart.
This should solve your Ethernet not working but Wi-Fi ok issue.
Kind regards 3os.