Wired Unmanaged - Ubuntu desktop issue

I have installed a GNOME desktop on my Ubuntu 18.04 server. The installation went well, I can login and etc. However, some of the netwrok services/features do not work.

For example I’m unable to enable Remote Desktop most likely due to “No Networks selected for sharing” message. Furthermore, I’m unable to connect using the top right menu. I only get message “Wired Unmanaged” as shown below:

unmanaged-network-ubuntu-issue

Interestingly my host has IP address so I’m connected to LAN.

1 Like

With Ubuntu 18.04 Canonical introduced new network management called Netplan. In nutshell Netplan allows to directly configure network and/or switch between two network configuration daemons networkd and NetworkManager. By default networkd is configured for Ubuntu Server and NetworkManager for Ubuntu Desktop.

Since you mentioned that you have installed GNOME desktop on your Ubuntu server chances are that your system is still using networkd daemon hence your desktop has no access to the network configuration. To grant managed access of your network to your desktop open /etc/netplan/01-netcfg.yaml or /etc/netplan/50-cloud-init.yaml configuration file and change it:

FROM:

# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s3:
      dhcp4: yes

TO:

# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: NetworkManager
  ethernets:
    enp0s3:
      dhcp4: yes

Once ready apply changes by executing:

$ sudo netplan apply

Related article: How to configure static IP address on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org

Hope this helps

Lubos

6 Likes

Your solution worked. Thanks

This helped me a lot, Thanks!

superb Got it
Thank you very much

Really spot on
`

Thanks very Much!.

Had the server reinstalled - running virtual - and attempted all changes on Network-Manager without success.

In my case file was not there so created with correct renderer then applied netplan.

Issue Fixed!

Hello, I’m using Ubuntu 18.04.4 LTS for quite some time. However, my /etc/netplan folder is empty. I’m getting the same message.
unmanaged-network-ubuntu-issue

I installed netplan, but still this folder is empty. What should I do?

Thank you! That solved my issue as well…

I have pending this problem,please help

Hi Kalim,

Welcome to our forums.

At what state is your setup, you also see “wired unmanaged” at your top-right drop-down menu?

First of all Thank You so much!
Yes the same issue I am facing and I don’t know how to solve it…

Do you have a server setup with desktop installed later on? If so, you could try the above solution of configuring Netplan to use NetworkManager.

I have Ubuntu 20.04 LTS server installed, I have tried to use networkd and NetworkManager in its configuration file but still its not working.

Do you see any relevant error messages in the journal?