Blacklist command not available - blacklist kernel module - Ubuntu/Mint/Debian


#1

My wifi has locked out again been OK for over a year. Last time I had a problem I blacklisted the acer wmi and it worked fine. But when I tried to do the same again I keep getting a blacklist command not available message. Can anyone suggest how to reinstate the blacklist function?

Linux mint 18.3
Acer es 15 laptop


#2

Hi Phil,

Without more information I can only guess that you are trying to run blacklist as a command with the kernel module as a parameter on the Linux command line. Example:

$ sudo blacklist acer_wmi
[sudo] password for linuxconfig:
sudo: blacklist: command not found

Please note that the blacklist is an instruction only to be used within /etc/modprobe.d/ configuration files located in this directory. Given that the kernel module name you are trying to blacklist is called acer_wmi then execute following commands to create a new /etc/modprobe.d/blacklist.conf configuration file to blacklist the acer_wmi module.

Note: It is a good idea to check whether the /etc/modprobe.d/blacklist.conf configuration file does not already exists so you do not overwrite it. Alternatively use >> to append to the file in case the file already exists. In case the file does not exists the file will be created. Yet, another alternative is to simply use any text editor to edit the /etc/modprobe.d/blacklist.conf configuration file:

$ sudo bash -c 'echo blacklist acer_wmi >> /etc/modprobe.d/blacklist.conf'
$ sudo update-initramfs -u

The below image demonstrates the entire procedure. In this case we are blacklisting the aesni_intel kernel module. This procedure works on any Debian based Linux distros such us Mint, Ubuntu, Debian and more:

For more information visit: https://linuxconfig.org/how-to-blacklist-a-module-on-ubuntu-debian-linux

Hope this helps!

Lubos


#3

4 posts were merged into an existing topic: Broadcom Corporation BCM43142 - Linux Mint - not working


#7

A post was split to a new topic: Broadcom Corporation BCM43142 - Linux Mint - not working