Broadcom Corporation BCM43142 - Linux Mint - not working


#21

Hi Lubos
I started again through your instructions purged and reinstalled broadcom. also ran the command to remove blacklisted bcm43. no error report.ran modprobe b43 and tested the wifi before rebooting no wifi, did not make the changes permanent.
I have also tried running both options for drivers in the driver manage non worked so I reverted to recommended driver.

Im not sure how to see if drivers are blacklisted.

Could the problem be the acer wmi file which has caused problems n the past?

All the best
Phil


#22

Hi
I’ve been through the whole list of your suggestions again step at a time but still have no wifi, not showing in the icon with the wired settings.
Any other ideas? Or are any of the steps worth trying again?

All the best
Phil


#23

Hi Phil,

It seems that the wl module is loaded for your Broadcom card. Let’s try to swap that to b43:

$ sudo modprobe -r wl
$ sudo modprobe ssb
$ sudo modprobe b43

Please post any output of the above commands. After these run the wireless-info again and paste the results. These changes will not be permanent, a reboot will reverse them - we’ll set them as permanent if they work for you.


#24

Hi Phil,

Sorry for a late reply as I was unavailable for past week or so. Did you fixed the issue? Have you tried @sandmann’s solution?

Alternatively, have you tried to boot Live Mint linux and see if the wireless works? ( testing for hardware issue ) If it works, try to run lsmod and/or wireless script to see what modules are loaded. Then can then try to mimic the module installation on your production installation.

Lubos


#25

Hi Lubos sandmann
Still no wifi I’m afraid did try sandmann’s solution but no sign of wifi did not reboot

phil@phil-Aspire-ES1-521 ~ $ sudo modprobe -r wl
phil@phil-Aspire-ES1-521 ~ $ sudo modprobe ssb
phil@phil-Aspire-ES1-521 ~ $ sudo modprobe b43
phil@phil-Aspire-ES1-521 ~ $ rfkill list
6: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
I did go through all the previous suggestions again just in case I missed something. Not sure what Live Mint linux is but willing to try with direction.

All the best
Phil


#26

Hi Phil,

With Live Mint I meant to simply boot Linux Mint ISO from DVD or USB but do not preform the installation.
mint-boot-linux-live
Once the Mint boots up just check if the WiFi is working and if yes check for settings. Best would be run the wireless script and paste the output here. This might give us some clue on what is going on.

Lubos


#27

Hi Lubos
I did boot linux live from my install usb which I eventually found. No Wifi option there either.
Phil


#28

Interesting! At this point I would say bring it over so I can have a look at it :grin:.

Hardware issue sounds unlikely especially when you mentioned that the problem started after upgrade.

But, I’m sure we are missing something but unsure what it is. Try some other distributions like Knoppix or Ubuntu to see if you get more positive results hence to as an attempt to dismiss hardware issue.


#29

Hi Lubos
Could the problem be that the acer wmi is in conflict with other drivers. I have tried to blacklist this but dont seemto be having success, mainly because I cant get the commands right.
Phil


#30

Hi Phil,

Your wireless-info.txt states that the acer wmi is indeed blacklisted:

You can try to move the file out of that directory (thus enabling the module), reboot, and see if something changes - you can always move it back later. I’d also advise boot with a recent Live Ubuntu as @Lubos suggested, and see if you have wifi that way - if there is, we can figure out what recent driver works with your hardware.


#31

Happy to give that a go, but how do I move the file out of the directory. I will need to find a recent live Ubuntu usb for the live boot.
Thanks for your time with this
Phil


#32

Hi Phil,

To move the file you can type:

$ sudo mv /etc/modprobe.d/blacklist.conf /root/

This will move the text file to the root user’s home directory. You’ll need a reboot for the modification to take effect.
To move it back if needed:

$ sudo mv /root/blacklist.conf /etc/modprobe.d/

You can also try to enable the other blacklisted modules the same way, but modify only one thing at a time, test, restore the original, and modify something else after that - this way you can keep track of what change made useful progress.


#33

Hi
I tried the command as suggested no wifi, no message after command input. I did reboot still no wifi Am I missing something? have not run the command to reverse. I am looking into trying a different distro, would buying the Mint 19 usb have any effect?

Best
Phil**
Phil


#34

Hey Phil,

Please do try Ubuntu live usb stick and see if booting from it results in a working wifi. You can use this guide on how to set up one.


#35

Hi Phil,

Any luck with this? As already suggested it is best if your try one or more Live Linux distro to exclude the possible hardware issue. Here are few things you can also try:

  1. While in your current Linux Mint installation play little be with the modules. Learn how to load and unload modules on running system.

  2. I would also try to install or reconfigure the bcm43 free software driver.

To do so run the apt command to install or dpkg-reconfigure to reinstall the driver:

sudo apt-get install firmware-b43-installer
sudo dpkg-reconfigure firmware-b43-installer

Lubos


#36

Hi Lubos
Tried to reload b43 and reconfigured still bo luck, am looking for a distro on USB tired a couple of live dvd but hav a dodgy dvd drive.
Phil


#37

Hi Phil,

When testing your WiFi try to also use command line to do so. This ensures that we skip any other overhead authentication/network configuration settings which could possibly produce false positive results.

What we are looking for is that after your run ( replace the below wlp3s0 with your interface name ):

$ sudo iwlist wlp3s0 scanning

You should see all wireless access points around you in which case WiFi is network interface works correctly.

Furthermore, if you laptop support USB booting simply create Live USB with gddrescue command as suggested by @sandmann using your current Linux Mint system.

Lubos


#38

2 posts were split to a new topic: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable) - Linux Mint