"Cheese" can't find the built in Camera

I am running Centos 8 on a Medion P6622 laptop which has a built-in camera. However, when running Cheese or a video conference (Jitsi) in a browser Linux doesn’t find the camera.
How would I go about to activate the camera???

Hi MalteseFalcon,

Welcome to our forums.

First of all, let’s see if the whole system knows about your camera device or not. Please check the output of the following command on your system:

# lshw

You can grep the output for camera or video devices. If you find your device, it means the operating system knows of the device, if not, it could be a driver issue.

Check our guide on how to test webcam on Linux.

As mentioned by @sandmann try to use the lshw command to check for your attached peripheral devices or alternatively execute:

$ ls -ltrh /dev/video*
$ v4l2-ctl --list-devices
$ dmesg | grep -i "Camera"

Hi Sandman and Lubos,
thanks for helping me with this issue!
I already had tried what is suggested in the guide on webcams in linux, but with no success.

Here is what happened with your suggestions:
lshw | grep -in video
lshw | grep -i camera
dmesg | grep -i "Camera"
returned nothing at all.

ls -ltrh /dev/video*
ls: cannot access '/dev/video*': No such file or directory

v4l2-ctl --list-devices
bash: v4l2-ctl: command not found…
Failed to search for file: cannot update repo ‘nux-dextop’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried; Last error: Status code: 400 for http://li.nux.ro/download/nux/dextop/el7/x86_64/ http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/x86_64/repodata/repomd.xml

What would you suggest next?

It does not seem that the camera is part of your system. Make sure that the camera is not disabled in BIOS.

The BIOS provides two possible settings for the camera : [disabled] or [last state].
It is set to [last state].

Meanwhile I found out that the Camera is connected with a keycode (xmodmap):
keycode 220 = XF86WebCam NoSymbol XF86WebCam NoSymbol XF86WebCam
Can this keycode be used to activate the camera???

I don’t know if this will help you or not, but on my (older) zareason laptop the F6 function key enables/disables the built-in webcam which i didn’t discover for the longest time…

Thank you very much for the hint, but it doesn’t work.

I tried all the F-keys with and without the fn-key pressed, none activates the camera.
Is it possible in Centos Linux to bind keycode 220 to a Key on the keyboard – lets say to (shift)F12???