COnnection issues after netplan apply

I am new to Linux server admin but since I installed Ubuntu on a home PC, naturally I was assigned setting up a server for out IT Ticketing system.
Long story short. I have set up our netplan for static IP and the admin has set the entry in the DNS. the issue is when I apply the netplan, I am no longer able to ssh into the server and I am not able to ping any site(internal or external) and I am not able to get updates (get a 101 connection issue). once I use dhclient -r and dhclient, I get a new IP address and I am able to continue setting up the server, able to ping and can go out and get updates no issue. Then I am not able to access the URL at that point so the server is down. Once I apply the netplan, I get my static IP and the connection issue continues.

When I try to ssh into the server, I get a connection refused right away, not a connection time out so the server is still online, just somehow being blocked. It is like that IP address is blocked.

Any hints or ideas is very much appreciated. I am on 22.04

Hi Matthew,

Yes, to me it feels like you static IP has been blacklisted or needs to be whitelisted. Just for a testing purposes have you tried to get a new IP address via dhclient , confirm that everything is working and than use the exact same IP address for you netplan static configuration?

If the new IP netplan configuration works and you can ping and access any page it means that there is nothing wrong with your netplan configuration and it might just confirm that your original IP address is blacklisted.

Also have you tried to play with traceroute command to see how far you get with both IPs. Example:

hope this helps…


I will try to set the new IP from dhclient in the netplan and then apply the netplan and let you know if that works. Thank you.

I am not sure about the IP address being blacklisted. but I changed the IP in the netplan and then we adjusted the DNS to match the new IP. everything is working. Thank you for help.

1 Like

Not a perfect solution as we still do not know the cause but good to hear that it works.