How to install Cinnamon desktop on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org


#1
This article will explain how to install Cinnamon desktop on Ubuntu 18.04 Bionic Beaver. Use this guide if you wish to change your default GNOME desktop to Cinnamon environment. See also our article: The 8 Best Ubuntu Desktop Environments (18.04 Bionic Beaver Linux) for more desktop environment choices.
This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-cinnamon-desktop-on-ubuntu-18-04-bionic-beaver-linux

#2

Brad West

I upgraded 17.10 to 18.04 and it removed Cinnamon during the upgrade. I’m now trying to reinstall it and getting a similar error to Johan:

cinnamon : Depends: cjs (>= 3.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I try to install cjs I get:

cjs is already the newest version (3.6.1-1~artful0).

Not sure what to do about this. Any help would be appreciated.


#3

Eisen Heim -> Brad West

Try sudo apt autoremove.
Seems it worked for me


#4

Hlaode -> Brad West

I’m getting the same problem, please reply if you find a solution.
-edit
This worked for me:

https://askubuntu.com/questions/1029743/unable-to-log-in-to-cinnamon-session-18-04

https://askubuntu.com/questions/1012087/cinnamon-session-crashing-login-from-greeter


#5

Johan Larsson

Freshly installed 18.04, and there’s a conflict that prevents installation. “Unable to correct problems, you have held broken packages.” I think it’s libcjs0-libcjs0f that excludes each other, but are both needed, sort of…?


#6

This worked fine on a fresh install system for me after reboot. Why did I have to reboot? I enabled ctrl+alt+backspace to ensure X was killed and it didn’t work so I didn’t expect the reboot to fix it either but it did. Just wondering why I actually needed to reboot?


#7

Yes, you are right, there is no need to reboot. In fact there is never a need to reboot the Linux system unless you have installed a new kernel etc. However, depending on your situation rebooting seems to be the simplest solution.

We are changing Display Manager from gdm3 -> lightdm so unless you know how to access command line using TTY’s and how to launch the lightdm display manager from command line you better simply reboot your PC and your are done.


#8

No my point is that I did need to reboot and I have no idea why because you’re right that we shouldn’t have to.


#9

Hi Joseph,

My apologies, I misunderstood your comment. I thought that you successfully changed from GDM3/GNOME --> LIGHTDM/CINNAMON without rebooting your system and suggesting that the tutorial should be updated.

Here is how you switch from GDM3/GNOME to LIGHTDM/CINNAMON desktop without reboot.

  1. Given that you have already installed cinnamon desktop as instructed by this tutorial, open terminal and enter $ sudo systemctl stop gdm3. This will terminate GDM3 display manager
  2. Using your mouse simply log out from Gnome desktop.
  3. Since we have already stopped the GDM3 display manager you will be now presented with a black terminal screen on TTY1 dedicated for GUI. Switch to some other TTY e.g. CTRL+ALT+F3. Login with your user credentials and execute: $ sudo systemctl start lightdm. This will start lightdm display manager. Select Cinnamon desktop and login.

hope this helps…

Lubos


#10

Just curious. (Because I just installed 18.04) why is there no where in the article telling someone how to ADD the Cinnamon REPO? I followed along with your instructions?..and it told me it couldn’t FIND the “cinnamon-desktop-environment” OR “lightdm” isn’t that something that would reside in a repository for Cinnamon? Like I said…“just curious”


#11

Hi Eddie,

Both packages are located within universe repository which should be enabled by default. Not sure why this is not the case with your system. However, it does not hurt to include an extra line to the tutorial:

$ sudo add-apt-repository universe

to make sure that readers have the universe repository enabled.

The article will be updated to reflect your suggestion shortly.

thank you


#12

I added this. The reply I got from my terminal is: “sudo: add-apt” command not found.
Sup dat?"


#13

Ignore this last post. evidently I added it wrong. (Something I, personally, have NEVER done before).