How to install Discord on Linux - LinuxConfig.org


#1

However, the Discord developers do plan on supporting Linux and have even released an experimental ‘canary’ version that you can install and use now. It’s definitely not perfect, but it does work fairly well, and, if you’re a gamer, why miss out?


This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-discord-on-linux

#2

Mathieu Jobin

installing the .deb via dpkg did not work for my on ubuntu 17.10

but fear not, we have now snap

$ snap install discord # GUI prompted user password for sudo rights automatically
discord 0.0.5 from 'snapcrafters' installed

#3

Holimoli Eutasin

That for Ubuntu did not work kit the error message:

dpkg: Error while editing the archive /path/to/discord.deb (--install):
The archive can not be accessed: file or directory not found

Errors occurred while editing:

/path/to/discord.deb


#4

Mathieu Jobin -> Holimoli Eutasin

likely you can replace /path/to/discord.deb by ./discord.deb as it downloaded in the current dir.
or even strip the ./ altogether. the idea here is that it is common practice in documentation /path/to/ to refer to wheever you downloaded it.

obviously /path/to/ does not really exist on your system.

alternatively, you can try snap install discord


#5

Linrade

To get discord installed on openSUSE Leap 42.3 you need to add 2 openSUSE repositories:

“zypper ar -f http://download.opensuse.org/repositories/devel:/tools:/compiler/openSUSE_Leap_42.3/ devel:tools:compiler”

"zypper ar -f http://download.opensuse.org/repositories/games:/tools/openSUSE_Leap_42.3/ games:tools "
“zypper ref”
“zypper in discord”

accept the openSUSE repo keys and at last the package dependencies

The “alien” approach above didn’t work for me, discord crashed. Could be due to the libc++1 lib missing…


#6

Caleb Hawn

Awesome article! I thought this was just gonna be a normal article or something, but then I freaked out when I saw that you actually gave the commands to actually get the app. I was like, “Thank you, website!” Then I find that you use Disqus for your comment section instead of making users make a website. For these reasons, I have no choice but to check out more of your website.


#7

Ria Hawk

I’m using Linux Mint 18.3 64 bit. I’m able to install the .deb file, and it will start and seems to work fine, but whenever I get a message through Discord while I’m doing something in another window/program, my whole system locks up. I can’t move the mouse, and they keyboard doesn’t seem to register anything. It just sits there and nothing responds.


#8

Caleb Hawn -> Ria Hawk

I can see why that could be a problem. You should report that to Discord so they can try to fix it. That’s the whole point of these canary builds, so they can make it better and learn why things like that happens.


#9

Hell on Wheels

I use Debian, and I just keep getting command not found.


#10

TrediC

Elementary os has grey screen also i run sudo apt-get -f install it worked to me.


#11

Alejandro Palacios

Anybody else getting the red corrupt banner on Linux (using Fedora 27), don’t know how to fix that. cheers,


#12

Alejandro Palacios

dnf install libcxx fixed the gray window in Fedora 27


#13

BradC

Got this working on Fedora by installing libcxx and libcxxabi


#14

ElectronicLogic

Confirmed installing libc++ resolved issue of grey window.


#15

Tuuba

Hi,

openSUSE now has Discord packages contributed on the Open Build Service;

https://software.opensuse.org/package/discord

Under no circumstance should the deb conversion be done - you’ll end up with a broken install due to LLVM requirements (It requires new Clang)


#16

Zlatan Kovačević

Hell, a lot of people seem to have issues with “blank window in an amusing shade of gray”, I am one of them.
Googling the issue points to libc++ not being installed, however, I have issues installing it on Arch.
You can try installing it on your distro.


#17

Tom Chun

discord isi blank what do I do?


#18

Kromper

The Discord binary yields a blank window in an amusing shade of gray on Ubuntu.


#19

Donutsahoy -> Kromper

sudo apt-get -f install discord

If that doesn’t work

sudo apt-get install libc++1

Should work after that


#20

Kromper

The Discord binary yields a blank window in an amusing shade of gray on Fedora.