How to install Mate desktop on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org


#1

The objective is to install Mate desktop environment as an alternative desktop environment. See also our article: The 8 Best Ubuntu Desktop Environments (18.04 Bionic Beaver Linux) for more desktop environment choices.


This is a companion discussion topic for the original entry at https://linuxconfig.org/how-to-install-mate-desktop-on-ubuntu-18-04-bionic-beaver-linux TRANSFERRED FROM LINUXCONFIG DISQUS COMMENTS:

#2

zhaarteth

$ sudo tasksel install ubuntu-mate-desktop
xserver-xorg install
tasksel: apt-get failed (100)

Lubos Rendek -> zhaarteth
executing:

$ sudo apt update

should fix this issue

zhaarteth -> Lubos Rendek
Yeah, tried that. Ended up just using apt to install instead of tasksel.

Lubos Rendek -> zhaarteth
I’m unable to replicate your tasksel: apt-get failed (100). Tasksel works normally for me. Anyway, thanks for reporting this issue…


#3

Aprie Sastra
Thx its works for me


#4

Xamanek Martinez -> Lubos Rendek
the issue appears to be caused by autoupdates running in the background, you either wait for them to complete or reboot and fire up a terminal and execute “sudo tasksel install ubuntu-mate-desktop” asap.


#5

I got the same error message as the OP, and can confirm that reboot and then quickly try again works perfectly. Thanks


#6

Hi, I followed the instructions to install the Mate desktop but never saw the lightdm screens you show so couldn’t choose to boot to Mate rather than standard desktop. When I boot it shows the Mate logo but continues as before. What command do I need to find this choice and invoke it so as to boot to Mate environment?

Cheers


#7

@Tommo: You have to select the Mate desktop option during login. Click the small gear button besides the Sign In button and you will see the list of available environments.