How to install the NVIDIA drivers on Fedora 29 Linux -

In this guide you will learn how to install NVIDIA drivers on Fedora 29 Linux. First, we will be disabling the default nouveau opensource nvidia drivers and then install the official Nvidia driver.
This is a companion discussion topic for the original entry at

So I attempted your guide on installing NVIDIA drivers and not suprisingly after running the first reboot (Step 5) I was welcomed to a black screen. I say not surprisingly because I disabled the nouveau driver in step 4 and I kind of expected it. From this point I had no idea how to install the NVIDIA driver as I could not see what I was doing. So I guess I am seeking some more information on this process. Question 1: Is there a way to open a terminal that I am able to see after the reboot of step 5 so that I can install the graphics driver? (Note: I did have Wayland disabled in /etc/gdm/custom.conf) Question 2: Should I have switched from gdm to sddm before rebooting? (if so, is this confirmed to work because I don’t want to have to reinstall fedora again) Question 3: Is this process different/better than just installing the driver from the Software center under Add-Ons/Hardware Drivers?

Just hit CTRL+ALT+F3 or CTRL+ALT+F5 and so on. This will open up TTY console where you can login.
Well this could work too. But it is up to you. Now just go into TTY and execute the commands to switch to sddm
Unless the software center has latest Nvidia drivers the result is different.

Lubos, thank you for answering my questions. Installing and enabling sddm** before the Step 5 reboot worked great and allowed me to see therefore enabling me to get the driver installed on my desktop PC.

**Note: For anyone planning on attempting this installation method I would recommend installing and enabling sddm (as in shown in the Warning) before the step 5 reboot. You can revert to the gdm after you have the driver installed and rebooted by disabling sddm and reenabling gdm.

So the driver install worked great on my desktop, however when I attempted it on my laptop with hybrid graphics it didn’t work so well. The installation went through fine, but upon reboot the fedora logo flashed on the display and then the RoG splash screen came back with no further progress towards booting up the OS. I don’t know if you (Lubos) or anyone else has any ideas on what the issue is and/or how to fix it, but any help sure woudl be appreciated. The specs of my laptop: ASUS G46VW-BSI5N06 w/ 3rd gen i5 2.6ghz, NVIDIA 660M, 8gb ram. Note, I tried to install the 410.93 driver which was the most current non-beta available from NVIDIA compatible with that GPU. Also only have Fedora 29 running/not dual booting.

Want to share this in case it helps anyone. I’ve had persistent problems with the ‘black screen’ after disabling Nouveau, but I did find a way to make it work - for me. (nVidia driver version 418.43)

Had this issue on a GTA750 and GTX1050ti, with Fedora 29, fully updated 4.20.11-200.fc29.x86_64 as of today. I also have an onboard intel video card, I removed entries in the x11 conf file just for good measure (with a backup copy!)

So here’s my notes on this - I just today re-installed Fedora 29 after addressing some disk issues, and it worked like a charm (Thanks to this site, some other forums, and trial and error!). Didn’t need to reboot to the prompt or rescue for this at all - works on first try, in my case. Just be sure to do this all with no reboots until the end.

dnf groupinstall “Development Tools”
dnf install dkms “kernel-devel-uname-r == $(uname -r)”

dnf config-manager --add-repo=
dnf -y install nvidia-settings kernel-devel dkms-nvidia vulkan.i686 nvidia-driver-libs.i686
dnf -y install nvidia-driver nvidia-settings

Commented out all non-nVidia driver sections (for my intel onboard) in X11 display conf file

Disable wayland - just follow the comment to force login to use Xorg
Uncomment the line below to force the login screen to use Xorg

1 Like

Help! I have the same problem as Lord_Murphy – I failed to heed Lubos’ warning and I did not switch to sddm from kdm before disabling nouveau in Fedora 29 and rebooting (after all, kdm’s not gdm and the warning concerns only the latter, right?). So now I’m getting a black screen. Problem is that Lubos’ solution under Q1 doesn’t bring up a TTY console on either of my monitors. One is an older monitor with a DVI connection and is apparently recognized as primary by my Nvidia Quadro 2000 card but it went black earlier when I disabled legacy BIOS support in Windows (which I also have installed on my system and which I also cannot login into for the same reason) and my other monitor is apparently not considered primary by my graphics card because it has a DP connection. So is there anyway I can bring up a TTY console on either of my non-primary monitors? If I have misdiagnosed the issue here then please forgive me because I am a reluctant hacker who wishes to have as little to do with computers as possible but would just like things to work.

No sure why you are not able to get into TTY but you could try:

  1. When the system is booted, connect to it via SSH from another Linux box and update your desktop manager
  2. After you start your PC edit the grub ( boot loader ) menu to re-enable the Nouveau driver. This is just temporary however your system should boot into the system with Nouveau driver enabled giving you the option to update your desktop manager.