How to load kernel from grub menu


#1

What is the correct procedure for loading the Linux kernel from Grub2 terminal when your system fails to boot past grub (no graphic interface)
I’ve tried this method:

set prefix=(hd0,gpt1)/grub
set root=(hd0,gpt1)
insmod normal
normal
insmod linux
linux /vmlinuz root=/dev/sda1 ro
initrd /initrd.img
boot

but get
error: no image found

I know you can type in

ls (hd0,gpt1)/

and hit tab to bring up all available options, but I’m not able to find the correct file that contains the kernel??


#2

Hi Dlwilson88,

What are the entries that come up on the

Command that you mentioned? Which of them did you try booting with?


#3

I ended up completely removing and than re-installing Linux Mint 19 “Tara”…
I have been keeping notes on 8x10 index cards for any issues or problems that I would run into ( over 500 accumulated so far) and somehow I either didn’t write down the steps to recreate the issue or lost that card…
I think it would simply show

efi

then

EFI

then

ubuntu

then lastly

grub64.efi

and that’s where things ended ,

I’m fairly new to linux and the bash shell and then throw the grub2 terminal into the mix and I start to get a little overwhelmed with the amount of info you have to learn to execute the proper command to fix something that seems like would be a simple fix…

(Too used to running Windows troubleshooting I guess)

I’ve been using the new Linkedin Learning tutorials (formerly Lynda . com) to do alot of my self learning amd some youTube…

sorry I wasn’t prepared to help answer my own question…

I’ll have to make sure I have all the pertinent info before I ask a question next time…

Not sure if this helps but the initial file system structure went like this:

/dev/sdb1 boot.esp
/dev/sdb2 /
/dev/sdb3 /home
/dev/sdb4 /var
/dev/sdb5 /tmp

Mint was actually sdb on sda I had Kali-rolling installed


#4

Hi dlwilson88,

Since you have reinstalled the whole machine there isn’t really a way to find out what went wrong with the previous install, but that the system is up and running is what counts in the end. Sadly it is not always possible to wipe the whole machine…


#5

Pretty much what I figured since I essentially deleted all of my ability to recreate anything that got me to that point. I appreciate you taking the time t o respond, I am experimenting with the many different distros of Linux so when I run across another issue I will be sure to be more patient in my pursuit to correct the problem, before wiping the system…