Install And Set Up KVM On Ubuntu 18.04 Bionic Beaver Linux -

When you pair KVM with a graphical manager like virt-manager, it's extremely simple to use, and it integrates well with your Linux desktop. It's also simple to get VM guests on your regular network through bridged networking. This provides a more seamless experience overall.

This is a companion discussion topic for the original entry at

José Martins

In 18.04 - No WiFi after the bridge setup, so no internet.

Brian Law

after following this bridge setup I couldn’t get through to the internet anymore? the network links were all down and there was no default route for traffic

Pia Software

Here’s one netplan config that worked with Ubuntu 18.04 LTS:

version: 2
dhcp4: true
dhcp4: true
interfaces: [enp5s0f0]
dhcp4: true
optional: true

ming -> Pia Software

do you access guest host via enp5s0f0 or enp5s0f1? my machine has one interface and i chose static ip address, but once i built bridge between br0 and the ethernet interface (ens2), just as “Brain Law”, i lost internet access.


Use Gnome Boxes dudes. Way easier.

Daniel Cayea

18.04 doesn’t use /etc/network/interfaces but rather /etc/netplan/*.yaml file

ming -> Daniel Cayea

for 18.04 TLS, bridge definition doesn’t work under /etc/netplan. here is the link:

Michel Soares Pintor -> Daniel Cayea

# ifupdown has been replaced by netplan(5) on this system. See
# /etc/netplan for current configuration.
# To re-enable ifupdown on this system, you can run:
# sudo apt install ifupdown

Im having a similar issue to some of you guys. I used the network options in Virtual Machine Manager to create a bridge. Now just as many of you have said, I now have no network connectivity.

However I have learned that if I boot my VM, I suddenly have a network connection again.

So does anyone here know how to disable to bridge that was created by VMM (im assuming it was created using the same methods mentioned in this post), restore proper networking through netplan again, and then create a proper bridge using netplan?

Worked like a charm for me with these exact instructions; sure wish I’d found this before landing on those 10 other sites - thanks so much!

I don’t know if it was only me. But I installed all necessary packages and changed the interfaces file as discussed at the beginning. The next instruction is to reboot. Not sure which package it was but it made my xps 13 2018 edition with maxed ram and M.2 disk to take over an hour to boot up! The boot is hanging loading one of these packages not sure which one. I am running ubuntu 18 with pop O/S conversion. could be something in my Pop O/S. Also the Interface file modification made my wireless adapter stop working. I undid all the steps and my computer is working OK. i am getting a random system crash now.
If you have Pop O/S maybe think twice? :slight_smile: ha ha have fun!

I had reinstall 2 times after configuring the “interface” file. It took like FOREVER to boot my O/S up again. I took steps to see what was screwing with my Ubuntu.

I booted using a USB. I find the interface file on the USB. I located the file on my installed Ubuntu. I navigated to the file and right click. I chose to open up the path of the file in a terminal. I found the edited file with the items instructed to edit. I use ‘sudo nano’ to open the file. I deleted all the edit and replace the file info with the original. I closed the file and rebooted.

WHAT!? I was back on board. I am not sure what the instructions were meant for, but after reading the majority of the comments here, they need to be obsolete. I have a virtual machine up and running with no probs getting internet working on the box. Everything else is fine, just that ‘interface’ thing or whatever. I am rubbing my head like a monkey.