iwd cannot find resolvconf

I recently downloaded alpinelinux and i dont have ethernet connection. But i somehow managed to get it for a short time and downloaded linux-firmware and iwd for wireless connection. Everything works well except when i added NameResolvingService=resolvconf
since iwd by default use systemd resolv and this is openrc so i did that but with resolvconf iwd does not start at all. upon debugging i came to error: output of doas /usr/libexec/iwd
No usable resolvconf found on system
Module resolvconf failed to start: -2
D-Bus disconnected quitting

doas /usr/libexec/iwd -d further says that Trying to find resolvconf in $PATH and default paths

Hi Gamer,

Welcome to our forums.

Since the error message says it can’t find resolvconf and -d shows where it searches for it, a logical question would be if it is on your path or not, and if not, have you tried to add it?

@Gamer
According with Alpine Linux packagessearch for resolvconf, if you install openresolv then the resolvconf binary is going to be installed at /sbin/resolvconf.

Because /sbin is in $PATH, the installation of openresolv is going to (presumably) get you rid of that No usable resolvconf found on system.

Agree

Here are a few things you can try to troubleshoot this issue:

  1. Make sure that the resolvconf package is installed on your system. You can check if it is installed by running the following command: apk info resolvconf
  2. If the resolvconf package is not installed, you can install it by running the following command: apk add resolvconf
  3. Check the configuration files for the resolvconf module to make sure they are correct. The main configuration file for resolvconf is located at /etc/resolvconf.conf, and it should contain the correct nameserver addresses for your network.
  4. If the configuration files are correct and the resolvconf module is still not working, you may need to try restarting the resolvconf service. You can do this by running the following command: rc-service resolvconf restart