Kernel Panic- Not Syncing: Attempted to kill init!


#1

I am running Linux Mint 15 Cinnamon off a 32GB USB flash drive. I am doing a live boot of of the Kingston Technology Data Traveler G3 USB 2.0 thumb drive.
I am running Firefox 20.0 for Linux Mint- 1.0. The trouble is this: In the middle of surfing the browser locks up/freezes, the crashes & this message apears:

“Kernel Panic- not syncing: Attempted to kill init!”
“drm_kms_helper: Panic occurred, switching back to text console.”

Any idea as to what this means, what is causing it & how to fix?
Bootloader giving this type of error/problem?
Thanks for any help.


#2

Hi,

Have you tried some easy to take basic troubleshooting tests such as testing your USB on other computer? Do you have another USB stick to try? This error may also be linked to a RAM hardware problems.

Can you try to reboot and run memory test or try memtest command:


$ sudo apt-get install memtester

with memtest you can run a memory test always with less that it is installed. Here i run single test for 100MB:

# memtester 100 1 
memtester version 4.2.2 (64-bit)
Copyright (C) 2010 Charles Cazabon.
Licensed under the GNU General Public License version 2 (only).

pagesize is 4096
pagesizemask is 0xfffffffffffff000
want 100MB (104857600 bytes)
got  100MB (104857600 bytes), trying mlock ...locked.
Loop 1/1:
  Stuck Address       : ok         
  Random Value        : ok
  Compare XOR         : ok
  Compare SUB         : ok
  Compare MUL         : ok
  Compare DIV         : ok
  Compare OR          : ok
  Compare AND         : ok
  Sequential Increment: ok
  Solid Bits          : ok         
  Block Sequential    : ok         
  Checkerboard        : ok         
  Bit Spread          : ok         
  Bit Flip            : ok         
  Walking Ones        : ok         
  Walking Zeroes      : ok         
  8-bit Writes        : ok
  16-bit Writes       : ok

Done.

#3

#4