Monitor AMD Ryzen Temperatures In Linux with latest kernel modules - LinuxConfig.org


#1
AMD's Ryzen CPUs have been out for several months now, but AMD still hasn't released any specifications or code to get temperature monitoring support for CPU sensors in Linux. Thankfully, there are fairly accurate sensors on Ryzen motherboards, and they are accessible through Linux. You can only take full advantage of them by using the latest kernel modules, and in some cases, lm_sensors itself.
This is a companion discussion topic for the original entry at https://linuxconfig.org/monitor-amd-ryzen-temperatures-in-linux-with-latest-kernel-modules

#2

Code C

Hi I’m stuck on git clone https://github.com/groeck/it87.git

I get ‘remote: Repository not found.’


#4

Ken Stailey

Even in Bionic the it87.ko driver is too old and does not support newer chipsets

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1740736


#5

trotos

Hi, on that step I get the following error:

$ sudo mount /dev/sda1 /boot
$ sudo make install

cp nct6775.ko /lib/modules/4.13.0-36-generic/kernel/drivers/hwmon
depmod -a -F /boot/System.map-4.13.0-36-generic 4.13.0-36-generic
depmod: FATAL: could not load /boot/System.map-4.13.0-36-generic: No such file or directory
Makefile:35: recipe for target 'modules_install' failed
make: *** [modules_install] Error 1

any idea what should I do?

board is an asrock ab350m pro4


#6

Henry Paul

I have the ASROCK Taichi x370 and mine is working with nct6775. Ubuntu 16.04 4.4.0-96-generic


#7

romulous75 -> Henry Paul

I had a ASROCK Taichi x370 board, sensors worked out of the box on Solus. But the bios flashing was really bad. I ended up bricking it. Pity, was a nice board.


#8

Tirel Antony

Thank you so much! :slight_smile:


#9

entropyfoe

How long typically until these modules make it into the kernel?


#10

entropyfoe

When would you expect that these modules would make it into the kernel?
How long does this usually take?


#14

AMD Ryzen C6H Ubuntu 18.04 kernel 4.17.12-041712
in .conkyrc
CPU Temp: ${hwmon 1 temp 1}°C
GPU Temp: ${hwmon 0 temp 1}°C


#15

Trying to do this on Ubuntu LTS 18.04. Something must have changed since this article was written:
linux-headers is a virtual package with somewhere around 40 options, one of which must be explicitly selected.

How do i know which of the various numbers and abbreviations i need?


#16

Hi @SnowAtYT

Try the following command instead:

$ sudo apt install build-essential bison flex linux-headers-$( uname -r)

The above command will install linux-headers to match your currently running kernel version.